BUG: Bot App & Event Subscription for user always sets scope to chat_message:read:admin

When we create a bot app event subscription we are given two options:

  • All users in account
  • Only users installed the app

You would except that the scopes for them would be different:

  • chat_message:read:admin for All users in account
  • chat_message:read for Only users installed the app

However in both of above cases it sets the scope to chat_message:read:admin which is a bug.

End Result
The end result is that a normal user cannot install the app then because of (incorrectly) assigned admin scopes:


Hey @attock

Thanks for posting on the Zoom Devforum! I am still learning, but I will try my best to help answer your question. :slightly_smiling_face:

Checkout this related thread that may have the answer you are looking for:

If this thread did not help, please let us know by replying back here and someone from the Developer Relations team will get back to you shortly.


Not really. Is this a search bot?

Hey @attock,

Since Chatbot Apps are Account Level, you cannot add the chat_message:read scope.

Setting either of these webhook options does not affect the scopes of the app, but setting which specific webhooks you want to subscribe to does.


Thanks for responding, to clarify the following is true:

  1. Since chat bots are account level, only admins can install the bots

Other questions:
2. What impact if any All users in account & Only users installed the app has on the apps?
3. Is there any way for a non-admin to install a chat bot at all and only receive chat messages for the user that installed the app?

Hey @attock,

Good question, this will trigger the respective webhook notification for either all users on the Zoom Account with the Chatbot App installed, or just for the user who installed the app.

Either an Admin, or a user who has the respective account permissions can install the Chatbot app.

Once the Chatbot is installed, you can simply only send Chat Messages to the person you choose.

Does that answer your questions?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.