Can't join meeting with cutomized UI in v5.7.1.1266

Run the sample app included in zoom-sdk-android-5.7.1.1266.zip,
set to use Customized UI, join a meeting in API User screen.
No response after tap the button, ApiUserStartMeetingHelper.getInstance().joinMeetingWithNumber returns 0 but onMeetingStatusChanged is never triggered.
Please note no problem when use Zoom Meeting UI with the same data.

So a bug for Customized UI? or any other thing need to be handled?

thx

3 Likes

I’m having the same problem.
I’ve authenticated using JWT in the sample app included in zoom-sdk-android-5.7.1.1266.zip.

When I enable the customization UI and start Instant Meeting, the screen transition is not performed …
If I disable the customization UI, the meeting starts without any problems.

I’m having a hard time with this because my app is based on customization UI.
Thank you.

Hi @kevinxiao and @maehata, thanks for bringing this to our attention.

There does appear to be an issue with the meeting status callback not working properly when custom UI mode is enabled. We are investigating this and will keep you updated as soon as we have any additional information.

We absolutely understand the impact of this and are treating it as a high priority issue.

Thanks!

Hi @maehata and @kevinxiao,

We have published a new version of the SDK that has resolved this issue. Please let me know if you are still seeing any issues after downloading it from the Marketplace. Note that this version has replaced the previous 5.7.1 version of the SDK that was published last week.

Thanks!

hello @jon.lieblich

Thanks for your reply. Verified can join meeting with customized UI in v5.7.1.1267 now.

But I encountered other problems:

  1. create a meeting via API, then join the meeting with meeting id, password and ZAK in app.
    In previous versions, the user will be treated as host/co-host and can join meeting directly.
    But in v5.7.1, it shows “waiting for the host to start meeting”.
    Can replicate this in the sampe app
    Screenshot_2021-08-20-16-45-06-472
    Is this expected behavior? if yes, how can I start the meeting?

  2. in v5.7.1, for the same user, the user id passed to onUserAudioStatusChanged is different from other callbacks like onUserVideoStatusChanged. Can replicate this in sampe app with customized UI.
    Is this a bug or expected behavior?

Thanks.

Hi @kevinxiao,

Glad to hear your custom UI implementation is working correctly!

Regarding the issue with joining a meeting, can you please provide a code snippet showing how you are attempting to do so?

in v5.7.1, for the same user, the user id passed to onUserAudioStatusChanged is different from other callbacks like onUserVideoStatusChanged . Can replicate this in sampe app with customized UI.
Is this a bug or expected behavior?

The user ID should be the same. I am aware that similar issues have been reported with the iOS SDK, so we will need to look into this to determine what is causing this behavior on both platforms.

Thanks!

hello @jon.lieblich

as I mentioned above, this can be replicated in the sample app, please refer APIUserStartJoinMeetingActivity#onClickBtnJoinMeeting,
ApiUserStartMeetingHelper.getInstance().joinMeetingWithNumber
No matter if customiszed UI is enabled or not
thx

Hi @kevinxiao,

Thanks for the additional context. We are aware of a change in behavior when joining a meeting as the host in the latest version of the SDK. However, starting the meeting is the intended use case here, which is working properly. Can you confirm that it is working properly if you instead try to start the meeting?

Thanks!

Hi @kevinxiao,

There was a recent service disruption reported where customers were unable to join meetings. It has since been marked as resolved on our status page, and I am no longer able to reproduce this issue. Please let me know if you are still able to reproduce this.

Thanks!

hello @jon.lieblich

I can join meeting with SDK v5.7.1.1267
thanks

Yes confirmed meetingService.startMeetingWithParams works, the meeting can be started successfully.
But for the userId in StartMeetingParamsWithoutLogin, what is the expected value for it? seems I can set it to any value when start the meeting?

Thanks

Hi @kevinxiao,

I’m glad to hear you’re also seeing that issue resolved!

But for the userId in StartMeetingParamsWithoutLogin , what is the expected value for it? seems I can set it to any value when start the meeting?

This is the userId that can be retrieved through the REST API. When you schedule a meeting, you can obtain this through the host_id field in the response. Alternatively, it is also returned through the Get a user API. If you have any additional questions around how to use the REST API to retrieve this value, please feel free to post over in #api-and-webhooks. :slightly_smiling_face:

Thanks!

hello @jon.lieblich

  1. what is the usage of StartMeetingParamsWithoutLogin#useId?
  2. as I tried, I can set the userId to any value other than the host_id returned from API response when start meeting, is this the expected behavior in SDK? Will there be potential problems if I don’t use the host_id?
  3. if more than one users use the same userId and zoomAccessToken to join the same meeting, seems this is allowed right? will there be potential problems if we do this?

Thanks.

Hi @kevinxiao,

  1. what is the usage of StartMeetingParamsWithoutLogin#useId ?
  2. as I tried, I can set the userId to any value other than the host_id returned from API response when start meeting, is this the expected behavior in SDK? Will there be potential problems if I don’t use the host_id ?

I did some testing here, and you may be able to avoid retrieving the user ID from the REST API. This used to be a required field a while back, but I do not recall what the reasoning was. We can do some investigating on our end on this and get back to you.

if more than one users use the same userId and zoomAccessToken to join the same meeting, seems this is allowed right? will there be potential problems if we do this?

It is actually possible to join the same meeting as the same user from multiple devices, so yes you should be able to use the same ZAK value. Keep in mind that using a ZAK is the same as having a user logged in, so you should not be sharing the ZAK with other Zoom users.

Thanks!

hello @jon.lieblich

Thanks for your reply.

So to confirm again

for a meeting created via API, meetingService.joinMeetingWithParams can’t start meeting in v5.7.1, need to call meetingService.startMeetingWithParams

Is this confirmed as expected change in v5.7.1 but not a bug?

the userId passed to onUserAudioStatusChanged is different from other callbacks

Any update for this? will there be a new SDK release soon?
Or anything I can do in my code to resolve this problem temporarily?

Thank you

Hi @kevinxiao,

Is this confirmed as expected change in v5.7.1 but not a bug?

As mentioned in a previous reply, this was seemingly caused by a service disruption. You mentioned that you were able to join meetings, is that no longer the case?

Any update for this? will there be a new SDK release soon?
Or anything I can do in my code to resolve this problem temporarily?

We are still investigating this and do not yet have any updates. I will be sure to let you know once anything changes. :slightly_smiling_face:

Thanks!

hello @jon.lieblich

Sorry I misunderstood that reply…
meetingService.joinMeetingWithParams still can’t start the scheduled meeting directly, I still need to call meetingService.startMeetingWithParams
Also replicable in sample app.
Please kindly advise.

Thanks.

Hi @kevinxiao,

Thanks for clarifying that this is still reproducible. We will need to investigate this. I will keep you updated as soon as we have additional information. In the meantime, I would suggest continuing to use the startMeetingWithParams approach.

Thanks!

hello @jon.lieblich any update for this?

the userId passed to onUserAudioStatusChanged is different from other callbacks

this is verified in v5.7.1.1268, thx

Hi @kevinxiao,

This should be resolved in the next release of the SDK.

Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.