Can't seem to turn the waiting room off for a user's Personal Meeting Room via the API

The userSettingsUpdate endpoint supports most of the personal meeting room details. You can set the personal meeting room’s passcode. But it doesn’t seem like the API supports disabling the waiting room for the personal room.

The docs show this option:

   "in_meeting": {
     "waiting_room": false,
   },

But it’s not affecting the personal room. Or if it’s supposed to then there’s a bug. It seems like that only impacts the waiting room setting for all non-personal room meetings.

If anyone has any insight or ways for me to troubleshoot, please let me know! We create a zoom account for each one of our clients and post it as a bookmark in our Slack channels so that we can have a persistent room for our dev/design team and our client to jump into and work. I’d like to be able to automate creating those accounts and need to disable the waiting room for the user’s personal meeting room. I can do it in the UI… so I’ll use that workaround for now. But I’d prefer to not have to open the web to adjust any settings!

Thanks,
Jon

I found that there are tabs in the API docs and that you have to pass query string parameters to the API to modify different aspects of a user. Seems a bit odd, but it worked. I guess you can’t upload images here, so this text below is from the API docs attempting to help show the names of the 3 buttons for folks that overlook this like I did. In my case, I needed to see the docs for the 3rd button [Meeting/Webinar Security Settings]

REQUEST BODY SCHEMA: application/json

User Settings

One of
[User settings] | [GroupSettingsAuthenticationUpdate] | [Meeting/Webinar Security Settings]