Change confirming consent for automatic recording

When you connect to a Zoom meeting with automatic recording there is a small strip on the top to agree to being recorded. Also, you mic and camera are disabled. These stay disabled until you click “OK” on the strip above. This “OK” is in a place that is not easy to see; there should be a big box on the center of the screen with more description about what is happening. Also, while this box is up you can still do a lot in the Zoom interface even though you haven’t agreed yet. Once the new dialog box is center stage, you shouldn’t be able to do anything in the Zoom interface.

If you do not click on the “OK” button on the top, eventually you are asked if you want to unmute yourself with a big box that pops up. Clicking on this does nothing because the first “OK” button has not been clicked and you are still muted and no camera. This tells me that this feature was not thought out because the previous code for the unmute was just copied with out taking into account the new automatic recording functionality.

I think that it is good to not have the camera or mic on until you have aggreged to being recorded. The old system may have started recording you and then asked if you wanted to be recorded.

But, if you are in a meeting and someone starts recording it your camera and mic do not turn off. So, you are being recorded before you are asked if you want to be recorded. This shows that the consent to recording in Zoom is not fulling worked out.

Also, maybe even if it just showing the black screen with your name in white in a recording is too much and this should be prevented as well.

Thank you very much.