Problem with Meeting Settings?

Description
This morning our users have noticed that they are asked to confirm recording when they start a meeting with the Zoom Web SDK. Previously this message box did not appear (see below screenshot).

There is a setting for this in the Zoom settings but we have it unchecked (setting is “Ask host to confirm before starting a recording”). Is it possible something has changed in the settings for this to make this confirmation appear even though the setting is turned off?

Which Web Client SDK version?
1.8.5

To Reproduce(If applicable)
I am attempting to reproduce in the sample app to determine if it is a problem without our meeting setup or with the version (1.8.5 vs 1.9.5).

I was able to reproduce this in Firefox and Chrome with meeting id ‘958 2883 6566’.

Screenshots
Screen Shot 2021-05-24 at 8.28.00 AM

Device (please complete the following information):

  • Browser: Chrome 90 and Firefox 87

@erichhansen

Zoom did a maintenance on their backend servers on May 22th and probably introduced this change without communicating

Therefore if Today is your first business day from that maintenance, your non host participants are going to see that message (even the hosts depending on your account settings.

You have an option to customize that message, unfortunately as reported here it does not work.
And as great news never come alone, you cannot remove this popup setting…

@MaxM Any official information about this change ?
Do you guys have an idea about the negative impact of such a change on our clients ? You base your popup on a global setting that is activated just for the chat, not for the audio or video, but your default message says to our clients that everything is being recorded. Since your customize disclaimer does not work and we cannot remove that behavior there is nothing we can do… seriously. Please fix this problem ASAP.

Hey @nvivot and @erichhansen,

Thanks for reporting this issue. This does sound like something we introduced on our end. Just to make sure that I have a good understanding before reaching out to our engineering team, are you able to provide steps to reproduce the issue?

Based on my understanding I can reproduce this by:

  1. Enabling automatic recording on a meeting
  2. Disabling Ask Host to confirm before starting a recording
  3. Starting a meeting with the Web SDK

Is that accurate? Further, you’re seeing this behavior regardless of the version that you use?

Thanks,
Max

@MaxM

Your setup to reproduce it is correct. You just need to activate automatic recording and probably check at least one item to record (in our case it’s only the chat)

This behavior is not dependent on the Web SDK version, it happens on 1.9.5 on dev/staging for us, and on 1.9.1 on production.

@MaxM to add to what @nvivot posted, we are on 1.8.5 so it seems to be independent of the version.

The steps to reproduce are accurate to what we are experiencing as well.

Hey @nvivot and @erichhansen,

Thanks for providing more information. I’ve tried reproducing this with the steps I provided but so far I haven’t seen the same behavior.

Regardless, I’ve reached out to our engineering team to see if they can provide any insight. (ZOOM-277160)

Thanks,
Max