Closed_caption is missing from accountSettings response

Description
closed_caption is missing from accountSettings response.

Error
Same as description.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Which Endpoint/s?
https://api.zoom.us/v2/accounts/me/settings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. GET https://api.zoom.us/v2/accounts/me/settings
  2. The response.in_meeting.closed_caption is missing

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Hi @CalvinWu

Thanks for reaching out to the Zoom Developer Forum and welcome to our community!
I am happy to help here!
Can you make sure that you have the feature enabled in your account before calling the endpoint?

Thanks for the reply. Which setting should I enable and how can I enable it?

I already enable both “Manual captions” and " Automated captions" under “In Meeting (Advanced)”, but the response still don’t have closed_caption.

In [14]: {k: v for k, v in s['in_meeting'].items() if 'caption' in k}
Out[14]:
{'closed_captioning': {'enable': False, 'save_caption': False},
 'manual_captioning': {'manual_captions': True,
  'allow_to_type': True,
  'third_party_captioning_service': True,
  'auto_generated_captions': False,
  'full_transcript': True,
  'save_captions': True}}

Also, shouldn’t the server still respond with closed_caption: false instead of omit it?
Or should I check closed_captioning.enable instead? is closed_caption replaced by closed_captioning.enable?

@elisa.zoom I enabled both “Manual captions” under the both PERSONAL → Settings and ADMIN → Account Management → Account Settings. I still didn’t see the closed_caption in the response. Even I tried to check closed_captioning.enable, the value is also incorrect. Any suggestions?

Thanks @CalvinWu
Can you confirm that you were able to get that field in the past? or is it the first time that you are trying to get it?
Thanks
Elisa

Thanks for the reply @elisa.zoom , yes, we can get that field in the past. Our integration test notice this field is missing since around April 21. And that field is also listed on the API document, so I suppose either the document is wrong or something else is wrong?