Create Meeting 400 Error From Last Night

Getting 400 Error While Creating Meeting Using API From Last Night
Simple Meeting Object Using JSON Request With Bearer Token
{
“topic”: “Test Meeting”,
“type”: 2,
“start_time”: “2020-12-21T08:30:00Z”,
“duration”: 55,
“timezone”: “Asia/Calcutta”,
“password”: “”
}

Getting Response :
{StatusCode: 400, ReasonPhrase: ‘’, Version: 1.1, Content: System.Net.Http.StreamContent, Headers:
{
Connection: keep-alive
x-zm-trackingid: WEB_e96267f560e3a3fc690598cf40689d1e
X-Content-Type-Options: nosniff
Pragma: no-cache
.
.
.
.
Content-Length: 26
Content-Type: application/json; charset=UTF-8
Expires: Thu, 01 Jan 1970 00:00:00 GMT
}}

Hey @classroom13,

Thank you for reaching out to the Zoom Developer Forum. I just have a couple of questions to get us started.

  1. What is the endpoint you are using
  2. Are you using JWT or OAuth?
  3. Do you get any error messages with that response?

Thanks,
Max

We are using JWT Token Method.

We have an admin account called classadmin@gla.ac.in and 98 sub accounts named as [classroom1@gla.ac.in], [classroom2@gla.ac.in] and so on.

Everything was working fine till 19th december and all APIs were working.

Since 20th december we are facing an issue described below

Using Master Account :

  1. Access Token Generation : Working
  2. API Call For Meeting Creation : Working
  3. API Call For Other Task : Working

Using Sub Account :

  1. Access Token Generation : Working
  2. API Call For Meeting Creation : Not Working [(Returning Error Code -1, Status and NULL), Sometime It Returning 400 Bad Parameters With Same Data]
  3. API Call For Other Task : Working

After This Thing We Have Come To Conclusion That Only Admin User Can Create Meeting Via API But No Sub Account Had This Privileges Which Was Working Fine Earlier.

Hey @classroom13,

Thank you for providing additional information. Just to clarify, you were/are using the Master Account Meeting APIs to accomplish this, is that correct?

Thanks,
Max

Sir,

We have to create around 1K classes per day which can not be possible to create using only admin user. We call meeting create API via same user in which account we want to create meeting.

Everything was fine just before 4-5 days but suddenly this is happing in our account all 98 licensed account are working under 99th admin account with single JWT App.

Even other APIs to get meeting data or usage reports are still working fine with same mechanism, only meeting create API returning 400, Code : -1, Status : NULL.

We were using the following process

/users/{userId}/meetings

This API has a daily rate limit of 100 requests per day. Therefore, only 100 Create a Meeting API requests are permitted within a 24 hour window for a user.

Did you find what was the problem, we are have the same issue

I am in touch with Zoom Technical Team since 20 December .
After 4 days and more than 3 accelerations they have replied with 3 conversations and given time after 1 week.
Due to this, Our university classes getting disturbed very badly.

But let me hope they will give time soon.
Still not found any solution.
Checked everything.

And It Is Coming After Zoom Latest Update 20 December.
That Meeting Create API Using Sub Account Not Working Only Master/Admin Account Is Working.

Hey @classroom13,

Thank you for your patience. I brought this issue to two internal resources who are experts in this matter and they recommended that I reach out to our engineering team. I’ve since engaged our internal engineering team and will update you when I have more information as to why these requests are failing. (ZOOM-230959)

Thanks,
Max

The Same Issue Also Facing By 400 Bad Request on creating recurring meeting Since 20 December Zoom Update Release As We Are Facing.

Hey @classroom13,

For the create Meeting API bug (error code 400 “-1” “null”) a workaround until we fix it is to pass the settings field and approval type in the API request. For example:

{
   ...
   "settings": {
      "approval_type":"{respective value here}"
   }
}

Please let us know if that helps! :slight_smile:

Thanks,
Tommy

1 Like

Thanks For This Temporary Solution.
It Is Working Fine Now.

2 Likes

Hey @classroom13,

I’m glad to hear that we resolved your issues! If you encounter any further issues or questions, please don’t hesitate to reach out.

Thanks,
Max

Hey @classroom13, @ahmedraafat200,

Just letting you know this issue will be fixed this weekend on the 9th. You will no longer have to use the work around after the 9th. :slight_smile:

Thanks,
Tommy