Create meeting gives me {"code"=>3000, "message"=>"You cannot schedule a meeting for me."}

Description
When I try and create a meeting using the API I get the error code 3000, “You cannot schedule a meeting for me”. If I try without an access token I get errors telling me I have the wrong access token, so I don’t think it has anything to do with my access token. Any help to point out what I’m doing wrong would be much appreciated. Thank you!

I have tried with both “User Managed” and “Account Level” apps and get the same error message regardless.

Error
{“code”=>3000, “message”=>“You cannot schedule a meeting for me.”}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Which Endpoint/s?

https://api.zoom.us/v2/users/me/meetings

How To Reproduce (If applicable)
Steps to reproduce the behavior:
Here is the code from the method in my Rails app where I am trying to create a meeting

def create_zoom_meeting
    access_token = current_user.team.zoom_access_token
    zoom_client_id = ENV['ZOOM_CLIENT_ID']
    zoom_client_secret = ENV['ZOOM_CLIENT_SECRET']
    uri = URI("https://api.zoom.us/v2/users/me/meetings")
    request = Net::HTTP::Post.new(uri)
    request.basic_auth("#{zoom_client_id}", "#{zoom_client_secret}")
    request.content_type = "application/json"
    request["Authorization"] = "Bearer #{access_token}"
    request.body = JSON.dump({
      "topic" => "topic here",
      "type" => 2,
      "pre_schedule" => true,
      "start_time" => "2021-10-31T12:02:00Z",
      "schedule_for" => "me",
      "timezone" => "Europe/Dublin",
      })

    req_options = {
      use_ssl: uri.scheme == "https",
    }

    response = Net::HTTP.start(uri.hostname, uri.port, req_options) do |http|
      http.request(request)
    end

    params = JSON.parse(response.body)
    puts "============> #{params}"
  end

I managed to get it working. I removed “pre_schedule” and “schedule_for” from the request body and now it is working fine.

The schedule_for is unnecessary because the URI references “me” and the pre_schedule option means something different to what I thought it meant. Basically when you pre_schedule the meeting doesn’t show up as active until you activate it (I don’t know how).

Anyway, I got everything working for me the way I needed it to.

Thanks for following up and confirming you got this working @emmetgibney