Crestron CP3 + Zoom Room (Mac Mini)

#1

Hi All,
So, I’m a Crestron programmer and I’m doing a installation/integration with Zoom Room in a client.

My Zoom Room is Intalled in a Mac Mini with Mac Os Mojave 10.14.4.
My Zoom Room Version is 4.3.1 (555.0307)

I did all the steps to turn on the ZR-CSAPI in my client zoom account to use the CLI to control the Zoom Room through the Crestron Controller (CP3).
The only thing that I did different is that I didn’t put a ssh passcode in the ssh configuration.

After enable the ZR-CSAPI, I run the PS Command to do the process verification, and the reply is “2591 ttys000 0:00.00 grep ZAAPI”. The SSH Loggin is enable at my mac.

And when I connect my CP3 in Mac, I can see in Crestron Debugger Software that they are connected, but when I send a command, after (more or less) 2 seconds, the system sends a “bye bye” message and close the connection. and Crestron reconnect again.

With this explanations can some give me a little light…lol I Believe that the problem is in the ZR-CSAPI activation, cause the PS Command is answer a different message that should be.

I Can send to you the screen shoots from all the steps that I did.

#2

Some things to check:

After you launch the Zoom Room on the Mac, it takes about 5 seconds for the zaapi process to launch. You may need to wait 5 seconds until the ps command shows zaapi running. The CP3 will also not be able to log in via SSH until the zaapi process is launched. But even if you set the passcode to an empty string in the Zoom Room web settings, the zaapi process should launch, and allow you to login via SSH using an empty string as a password.

If you intend to set the passcode to nothing, then double-check, and make sure that you have not accidentally entered a space in the passcode setting field on the Zoom Room settings.

Once the zaapi process launches, you should be able to log in to the Zoom Room. If you have set the passcode to nothing, then you should be able to login by sending an empty string for the passcode. You can check by using command line ssh:

ssh -p 2244 zoom@10.10.x.x

And then just hitting the return key to send an empty string password.

If you are still having problems, I suspect it is an issue with the Crestron not being able to deal with an empty string as a password; In this case, contact Crestron for support.

-Scott