Event Notifications don`t work


#1

I have created an application in the new marketplace:
https://marketplace.zoom.us
I set up event notifications and set a correct endpoint. However, no notifications were received. I also can’t access webhook API, since it requires webhook:admin scope which I can’t enable in my app’s permissions. I’ve tried different types of application (webhook only, publishable, account level, etc.), but no luck. My endpoint is working, access from the browser works just fine. I searched for information on your developer forums with no success.
My endpoint is using HTTP, can this be a problem?
Other features like REST API and authorization work just fine


#2

Hi @geordieleggie,

There might be some caching issues on our end, can you try to regenerate your webhook verification token? If that doesen’t work, can you send us your accountID/number and the app that you’re using?

Thanks


#3

Thanks for the quick reply.
I’ve tried regenerating the verification token, reinstalled the app. I’ve also contacted your support and activated free Pro trial by their suggestion. Now I can create and view webhooks from REST API, but I still don’t receive anything on my endpoint.

Account Details

Account No 50295523
Account ID MDYAUQ8sTM-nKMJtPhAqhw
Application ID, i guess: U1rqLTiFQcqWmrYeYeWIEQ


#4

Hi @geordieleggie,

I recently did a test using the webhook endpoint from your publishable app. Do you see any payloads for start or join a meeting from me?

Thanks


#5

Thanks, I’ve received your notifications, but they were GET requests, so they have no content in them. After that I’ve tried to use webhook notifications API and they work now (Webhooks that have been created via API are now received correctly at my endpoint).
But I still cannot get any event notifications from my apps. I tried regenerating the verification token without any effect.


#6

Hi @Michael_Purnell,
This is our corporate account 's profile. I’ve created another publishable app on this paid account. Webhooks work now, but they don’t provide enough events to track meeting updates, deletes, their status, etc. These types of events seem to be available through app’s notification events, but I still can’t receive them on my end. I’m now using HTTPS. Tried regenerating verification token in app settings, different app types.

Account details

Account No 1101295
App ID: ryjRq2I6T42jGVxQflCNMQ


#7

Hi @geordieleggie,

We delivered a new patch to update our webhooks, can you try to regenerate the verification token again and see if your getting the events now?


#8

Hi @Oleg_Anikin,

We just released a new patch to fix our webhook bug, can you try to regenerate your verification token again to see if the events are coming in?

Thanks


#9

Hi @Michael_Purnell,
We’ve regenerated verification token and reinstalled the app, but we still can’t receive event notifications on our endpoint.

Docs about event notifications witch we’ve used:


#10

Hi @Oleg_Anikin,

Can you confirm if the url that you’re using is behind a firewall? If so, you will need to accept request coming from our IP 34.195.31.70 OR 34.200.9.189.

Thanks


#11

Hi @Michael_Purnell,
We’ve checked our endpoint security settings, and we don’t have any type of firewall (also auth and webhooks created by REST API work fine).
We’ve checked “Webhook Call Logs” in marketplace and there’re only webhook logs that we’ve created from REST API v2, nothing about Event Notifications. Feels like events configured on “Event Notifications” tab don’t have any effect. Maybe this type of events works only for published apps (we’ve tested to install app from test and publishable URLs)?


#12

Hi @Oleg_Anikin,

The Webhook Call logs currently only show the webhooks from the developer site. We will enhance it to include all web hook types within Marketplace for our next release coming next month.
Both published and unpublished apps should work.

Can you try two things.

  1. I just tested your endpoint with my own OAuth app, can you check to see if you received any payloads from me?

  2. If you didn’t receive any payloads, could you change your endpoint to a public webhook site such as request bin or request catcher, to see if your payloads are actually going out?

Thanks


#13

Hi @Michael_Purnell,
Thanks for your suggestion and attention to our problem.

  1. No, we’ve received no requests and no records in server logs.
  2. We’ve tried the requestbin.fullcontact.com and events work fine.

Our administrators have checked all server logs, but they didn’t find any recorded event requests. The interesting thing is webhook API notification requests come through normally. Do you have any ideas what can cause this issue with event notifications?


#14

Hi @Oleg_Anikin,

Can you check to see if you are recieving any responses to the following IP addresses, 34.195.31.70 OR 34.200.9.189 ?


#15

Hi @Michael_Purnell,
We’ve receiving no requests from these IP-addresses. We also tried manually sending POST requests using external services and they are received without any problems. But we still wouldn’t get a single request from addressed you listed.
Our endpoint is https://zoomus.dev.cpslabs.net/zoom/event
Can you see request logs for our app or endpoint? Maybe there is some error occurring?


#16

Hi @Michael_Purnell, we’ve tried another event endpoint and notifications worked well. But on https://zoomus.dev.cpslabs.net/zoom/event we get nothing, no connections. It seems like our endpoint was blacklisted on your end or something?


#17

Hi @Oleg_Anikin,

We took a look at the our servers logs and we’re getting a timeout when trying to reach the specific server https://zoomus.dev.cpslabs.net/zoom/event.

Thanks


#18

Hi @Oleg_Anikin,

Can you check your load balancer or configuration logs to see if there were any errors. We’re using TLS 1.2 and sometimes the sever may drop the payload if there is a mis-configuration.

Thanks


#19

Hi @Michael_Purnell,
Thanks for your attention.
We’ve checked our configuration and find no problems there. Also we support TLS 1.2, here you can see results of TLS testing https://www.ssllabs.com/ssltest/analyze.html?d=zoomus.dev.cpslabs.net
We also tried to see if there is any http packets coming from your IPs using tcpdump and there is none.


#20

Hi @Michael_Purnell,
Thanks a lot, we don’t now what you’ve done, but event notifications were received correctly on our endpoint until 18:11 GMT+3. Now they aren’t received again. UPD: Problem was on our side, it’s solved now.

But there’s one issue - we were continuously receiving events from an Asian Account on https://zoomus.dev.cpslabs.net/event since Friday. These account credentials and their account verification token are listed below.

Account credentials

“account_id”:“MKDRWopTSPiByDupF4Lwow”
“verification_token”:“yG28ivf7sGO6VPn6Zt18”

Another one question/remark about API reference.
Here, https://marketplace.zoom.us/docs/api-reference/webhook-reference/meeting-events, it’s specified that “id” parameter for “Meeting Created/Deleted” event would be a string type, but in fact it’s an integer.
Same issue with "id’ parameter here: https://zoom.github.io/api/#retrieve-a-meeting