How can client detect the meeting password is invalid?

I tested the SDK behavior for invalid meeting password. I didn’t get MEETING_STATUS_FAILED with MEETING_FAIL_PASSWORD_ERR reason code. Instead, I saw the following status callback:
MEETING_STATUS_CONNECTING
MEETING_STATUS_DISCONNECTING
MEETING_STATUS_ENDED with reason 0

Which version?
v5.2.42037.1112

Hi @rjd

Thank you for using the dev forum!

If I read correctly, you want to know how the zoom meeting password is invalid? The way that you can know is when you go into the zoom app, you put the correct Meeting Code. Zoom will then take you you the password. If you type it wrong, it will not let you enter the meeting because there is no meeting with that password.
Hope this help,
Gabe
@PantherDeveloper

Hi @PantherDeveloper, I need a way to detect it programmatically from Zoom Windows SDK. I doesn’t look like the SDK calls IMeetingServiceEvent::onMeetingStatusChanged with the expected status code.

Thanks for responding @rjd

Have you tried to update zoom to 1.8.3? This might help.

Thanks,
Gabe
@PantherDeveloper

@PantherDeveloper, I am not sure about version 1.8.3. I am using the latest SDK from https://github.com/zoom/zoom-sdk-windows/releases

Hi @rjd

Thank for responding.

I might have to look on my windows and see if I get the same problem as you. I will respong back as soon as possible!

Gabe
@PantherDeveloper

Hey @rjd

Thanks for using the dev forum!

Hmm that does not sound like expected behavior. Can you share your join/start meeting code, so that I can talk with the team about this issue?

Thanks!
Michael

Hi @Michael_Condon,

Thank you for reply. The follow is the code snippet for joining the meeting:

    ZOOM_SDK_NAMESPACE::JoinParam params;
    params.userType                      = ZOOM_SDK_NAMESPACE::SDK_UT_WITHOUT_LOGIN;
    auto &api_user_params                = params.param.withoutloginuserJoin;
    api_user_params.meetingNumber        = _atoi64(meeting_id_.c_str());
    api_user_params.isDirectShareDesktop = false;
    api_user_params.isVideoOff           = true;
    api_user_params.isAudioOff           = true;
    api_user_params.psw                  = meeting_password_.c_str();
    api_user_params.userZAK              = sdk_user_zak_.c_str();
    api_user_params.userName             = user_name_.c_str();

    ZOOM_SDK_NAMESPACE::CreateMeetingService(&meeting_service_)
    meeting_service_->Join(join);

Thanks

Hey @rjd,

Are you receiving the same error when you try to join a meeting without using a ZAK?

Thanks!
Michael

It’s the same behavior with or without ZAK. I also noticed a slight difference between the following two scenarios

  1. provide empty password for meeting with password enabled:
    We received “connecting”, “disconnecting” and “ended with reason 0” events within a 200~300 ms window.

  2. provide incorrect password for meeting with password enabled:
    We received only the “connecting” event. We didn’t receive the other two. The SDK seems to hang somewhere.