How do I enable V2 webhooks API?

Hi,

We are currently using V1 webhooks API which is nearing its EOL. How do I enable V2 webhooks API?
I have searched the documentation but haven’t found any particular page which specifies the exact steps.

I found one page which reads ’ Your Guide to Migrating From v1 to v2 APIs’ but it doesn’t have the actual steps or the API calls to be made in order to enable V2 webhooks API.

I would greatly appreciate your assistance.

Thanks.

Hey @klassroom,

You will need to build a webhook app, or enable event subscriptions on either a JWT, Chatbot, or OAuth app.

Let me know if you need more info. :slight_smile:

Thanks,
Tommy

Hi @tommy,

We already have a webhook app and enabled event subscriptions on JWT.
But we are unable to enable the V2 webhooks API.
See the below thread on the error that we are getting when trying to enable it.

Can you help resolve this?

Thanks,
Purnesh

Hi @klassroom, as answered here, these are not supported.

Hi @michael.harrington
We have created as Webhook Only App and subscribed to the events that we are interested in. But the JSON that we get as part of the webhook call is not a valid JSON. Please refer to the attached screenshots. If you see the name fields are not within double quotes.

Thanks.

Hey @klassroom,

Are the webhooks themselves that are sent to your server valid JSON?

Thanks,
Tommy

Hi @tommy,
The webhooks sent to our server are also Invalid JSON. Please see the attached screenshot. There are ‘n’ characters in the JSON string.

Thanks.

Hey @klassroom,

Can you send the full JSON payload to developersupport@zoom.us along with the meetingID? We will debug the issue from there. :slight_smile:

Thanks,
Tommy