How to disable the “Require users to update the client” setting programmatically?

Our app started throwing Meeting Status: failed Meeting Error: clientIncompatible Meeting error reason: none out of blue.

ZoomSDKMeetingServiceDelegate: onMeetingStatusChange: State: ZoomSDKMeetingStatus(rawValue: 6), Error: ZoomSDKMeetingError(rawValue: 10), reason: EndMeetingReason(rawValue: 0)

This is just insane!

The error appears also when I try to join anonymously. Does it mean all the effort we put into building the app was futile? I don’t have any control over what settings people who send me links set in their accounts. What shall I tell thousand of my users who paid for my app? @jon.lieblich @TimZoom

We were told to disable the “Require users to update the client” setting.

How can we disable this programmatically? I hope we don’t need to ask thousands of users to do it manually? What shall we do here?

Which macOS Client SDK version?
v5.5.12509.0330

The same issue facing. waiting for the solution.

This is what has been shared with me:

You can disable this setting with the following steps (make sure you are doing this on the same account that is associated with your SDK credentials):

  1. Navigate to zoom.us

  2. Click on the “My Account” button in the top right corner

  3. If not already logged in, enter login credentials of your account

  4. After logging in, click on “Account Management → Account Settings” in the bar on the left side of the screen

  5. Search for “Require users to update the client” and disable the switch to the right of the setting

@ainsleyash10 please try if it works for you

Hi @tmiskiew and @ainsleyash10,

Thanks for sharing the steps to update this setting here @tmiskiew!

Please let me know if either of you are still experiencing issues after disabling this through your account settings. :slightly_smiling_face:

Thanks!

Unfortunately the instruction in incorrect and doesn’t work.

The option you described is off for the account associated with my SDK credentials.

How can it be that we get this error while using the latest SDK???

Do you guys understand that this completely broke our app?

There’s a similar issue here, have you seen this post? It may be worth checking through your code to see if the lines mentioned are included.

Thanks @alexmayo this doesn’t apply or fix the problem for us.

I just received an email from @jon.lieblich

This seems to be working as expected based on my testing and the information you have provided.

The latest version of the Zoom client is v5.6.4, whereas the latest SDK release is based on v5.5.1. If a user chooses to disallow older versions of the client from joining their meetings, the SDK has no way of overriding this setting. In order for any SDK app to join a meeting with this restriction, it is up to the user to modify their account settings to allow older client versions to join their meetings.

I am sorry if this is not clear in our documentation and will work with our documentation team to ensure this information is clearly spelled out. Please let me know if there is anything else I can do to help.

The SDK wouldn’t even tell you what version is expected on the hosting site. In fact even if you put forth effort to use the latest SDK your app may turn out to be incompatible and cannot even tell why because behind this SDK wouldn’t care to tell you. If you get incompatible client you can tell you users wait 3-6 month until zoom updates their SDK. And even that can turn out to be untrue.

This post should be added to the before you start section @TimZoom Pleae read before you waste time with our SDK

Hi @tmiskiew,

Thank you for the feedback. We will be adding additional information to our documentation regarding how this can impact the SDK’s ability to join meetings if enabled, and how a Zoom user can change this setting to better support SDK users.

Thanks!

@jon.lieblich documentation is definitely helpful but in this very case it doesn’t solve the underlying problem.

The problem is that turning this setting off or on in the account of the SDK developer has ZERO impact on anything.

This setting needs to be switched off in the account hosting a meeting / providing the meeting URL.

For a better understanding of the criticality of the problem let me give you this example.

I’ve built a commercial app. Someone pays for my app and receives a meeting invite from someone who happens to have this setting ON.

This means that the first time my client tries to use my app he just paid for he gets the IncompatibleClient error and there is NOTHING I or any developer can do about it.

I hope you understand that I cannot ask tens of thousands of users of my app to tell everyone they zoom with to turn this setting off otherwise the app they bought from me isn’t going to work.

The way Zoom implemented this setting is a killer for my app and all the developers out there because sooner or later everyone will hit this limit. As a matter of fact the zoom SDK will never ever match the client version of the Zoom client. So as soon as the host has this setting on its game over for all custom apps people have build on your SDK.

The SDK has a big problem here and it guys don’t fix it then everyone trying to build a product on it might be just wasting his time and resources.

Hi @tmiskiew,

To be clear, the documentation updates we are making are going to be the only immediate-term solution for this problem. We have been and will continue discussing solutions internally, but these are intended to be longer term fixes which would likely involve a non-trivial amount of engineering work. As of right now, the only way to resolve this issue is for the individual accounts to modify their settings if they wish to allow SDK users to join their meetings.

We absolutely understand the issue this creates. We are doing our best to ensure that we can find the best solution without compromising the integrity of any Zoom features, as there are non-SDK components involved on the back end.

Once we have any concrete details to share, I will be sure to provide an update here.

Thanks!