How to join meeting before host without setting role to 1 in meetConfig

Hello
I am developing an application that uses Zoom API and Zoom Web sdk. In the app user can create a scheduled meeting with option ‘join before host’ enabled.
The first issue I noticed was when participant tries to join the meeting which is not started by the host yet, a popup appears with text ‘Meeting is not started’. I found a workaround at this forum that says to set role to 1 to start this meeting as a host and it works but then I noticed another issue. The user which started the meeting becomes its host and when real host enters this meeting he is no longer a host so when he tries to end the meeting I can see an error 3003 (Not meeting host).

So the question is - how participant can start a meeting without becoming a host ?

Hey @Sergey,

Are you using your personal meeting ID by any chance? The Web SDK does not allow join before host with personal meeting ID on instant / scheduled meetings.

Thanks,
Tommy

Hi! We also have such problem with Zoom Web SDK. What we do: we create scheduled meeting with start date a bit earlier than current time via REST. Also we set join_before_host param to true and password. Than we connect to this meeting via Web SDK with role 0. This scheme was working in a couple of weeks ago, but now Web SDK can’t connect to this meeting with throw “Meeting not started” exception. So the question: is this scheme suitable for your vision of Web SDK usage and is it any chance that it will be fixed?

Hi @tommy,
Thank you for response, yes, we use personal meeting ID from the creation meeting response (docs)
Is there any other way to join meeting before host ?

Hi @tommy! Are there any updates about this issue?

Hello @tommy! We stuck with the same issue, any updates?

Hello @tommy,
I misunderstood regarding personal meeting id, we don’t use it.
I pass meeting id to Web SDK join method as meetingNumber. Anyway, the issue is after joining before host, participant becomes a host and then host can not end the meeting, is there something we could do about this ?

Hey @Sergey, @565189, @gavagava,

I was able to join before host using the Web SDK with role 0 (not as co host). Here are the steps I took:

  1. Scheduled a meeting without using Personal Meeting ID, and Join Before Host On:

  2. Joined the meeting with the Web SDK (I am using the Angular Sample App):

    Pass in role 0 and the other respective values.

  3. It worked:

Please try the steps I took and let me know if you can get it working.

Thanks,
Tommy

Hello @tommy,
I can still reproduce the issue by steps above.

There is response from creation meeting via Zoom API:
{
“uuid”:“yi0ylxRFTDeKYASMH9ojzA==”,
“id”:94891503470,
“host_id”:“cvkJmnYNRN-PeJwCraZJgg”,
“topic”:“Test”,
“type”:2,
“status”:“waiting”,
“start_time”:“2020-05-04T09:14:00Z”,
“duration”:60,
“timezone”:“America/Los_Angeles”,
“created_at”:“2020-05-04T08:17:31Z”,
“start_url”:“https://zoom.us/s/94891503470?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJjdmtKbW5ZTlJOLVBlSndDcmFaSmdnIiwiaXNzIjoid2ViIiwic3R5Ijo5OSwid2NkIjoiYXcxIiwiY2x0IjowLCJzdGsiOiJZVW1xYTU2TFZIM3djb29KN3lhOERQTGZkM2ZIc3R1Q1ZYdVFRcFdVYXdzLkJnVWdiREU0ZUhaVE5UQk9UVkpSV1daUVJreFFVRFJCTjBGcE5sbzJVbEJQU1hvQUFBd3pRMEpCZFc5cFdWTXpjejBBQTJGM01RIiwiZXhwIjoxNTk2MzU2MjUxLCJpYXQiOjE1ODg1ODAyNTEsImFpZCI6InpVdFp1cDFlUnhhYVhOTnJBaTF2NVEiLCJjaWQiOiIifQ.r_hqbxmEsGb-3VcloyH8DcSqaqCpvshFC6odEfhe2sg”,
“join_url”:“https://zoom.us/j/94891503470”,
“settings”:{
“host_video”:false,
“participant_video”:false,
“cn_meeting”:false,
“in_meeting”:false,
“join_before_host”:true,
“mute_upon_entry”:true,
“watermark”:false,
“use_pmi”:false,
“approval_type”:2,
“audio”:“both”,
“auto_recording”:“none”,
“enforce_login”:false,
“enforce_login_domains”:"",
“alternative_hosts”:"",
“close_registration”:false,
“registrants_confirmation_email”:true,
“waiting_room”:false,
“global_dial_in_countries”:[
“FR”,
“US”
],
“global_dial_in_numbers”:[
{
“country_name”:“France”,
“number”:"+33 170372246",
“type”:“toll”,
“country”:“FR”
},
{
“country_name”:“France”,
“number”:"+33 170379729",
“type”:“toll”,
“country”:“FR”
},
{
“country_name”:“France”,
“number”:"+33 170950103",
“type”:“toll”,
“country”:“FR”
},
{
“country_name”:“France”,
“number”:"+33 170950350",
“type”:“toll”,
“country”:“FR”
},
{
“country_name”:“France”,
“number”:"+33 756784048",
“type”:“toll”,
“country”:“FR”
},
{
“country_name”:“US”,
“city”:“New York”,
“number”:"+1 6465588656",
“type”:“toll”,
“country”:“US”
},
{
“country_name”:“US”,
“city”:“San Jose”,
“number”:"+1 6699009128",
“type”:“toll”,
“country”:“US”
},
{
“country_name”:“US”,
“city”:“Tacoma”,
“number”:"+1 2532158782",
“type”:“toll”,
“country”:“US”
},
{
“country_name”:“US”,
“city”:“Germantown”,
“number”:"+1 3017158592",
“type”:“toll”,
“country”:“US”
},
{
“country_name”:“US”,
“city”:“Chicago”,
“number”:"+1 3126266799",
“type”:“toll”,
“country”:“US”
},
{
“country_name”:“US”,
“city”:“Houston”,
“number”:"+1 3462487799",
“type”:“toll”,
“country”:“US”
}
],
“contact_name”:“Sergey Test”,
contact_email":"user@example.com”,
“registrants_email_notification”:true,
“meeting_authentication”:false
}
}

Then I try to join the meeting with role 0 and then I can see the following error in console - http://prntscr.com/saki4n
Meeting is not started, error code: 3008
The same is reproduced if create meeting via zoom aplication and use angular sample
I can’t join before host, the following error is occured - http://prntscr.com/sakxwl , but after host came in, I am able to join.

It’s interesting that we are still able to join the meeting from zoom application
Also I should clarify that if somebody joined the meeting via application, then I am able to join either

also encounter the same issue now here, everything as @Sergey described

I used the react sample app

Hey @Sergey,

After digging deeper, can you turn on the following setting at the account

or user level for the custCreate user:

Thanks,
Tommy

Hey @developer-whova,

Your join before host settings are also turned off. Please turn them on and try again.

Thanks,
Tommy

@tommy
Ok that is a very hidden setting :sweat_smile:

Some clarification follow up I want to ask.

  1. So this setting is separate from the meeting join before host setting?
  2. So for the sdk to join before host, the meeting host need to enable this in their global setting as well?
  3. How about meetings created from REST API?

@tommy thx for your investigation of this issue! Unfortunately for me it still repeated, even if I turned on all toggles in my settings you mentioned before. The issue is the same as described by @Sergey in this message, i.e. WebSDK throw 3008 error, but I can connect to the meeting before host via desktop app or via web browser with join url.

Check everything you said @tommy. Doesn’t seem to be working

Hey @developer-whova,

Good questions, the meeting host can just enable join before host for the meeting and it should work.

Did adjusting the settings work for you?

Thanks,
Tommy

Hey @gavagava, @565189,

Please message me the meetingID you are trying to join before host with and I will look at the logs. :slight_smile:

Thanks,
Tommy

Hello @tommy,

We’ve enabled appropriate setting in account. http://prntscr.com/sgou96
And after user creation we send additional request to set needed setting to true - http://prntscr.com/sgoy90

Unfortunately, it’s still not working.
I will create several test meetings and then send you ids to check the logs

I use client’s account for developing an application.
Below are listed meeting and user ids that I used for testing, hope this will help to find the issue.

92469886693
There were two attemtps to join meeting before host with role 0, message “Meeting is not started” was displayed and I could see error 3008 in debug.

95111212123
First attempt was to join before host and second attempt was with role 1

Users ids: UHOmBTpSSoC5kYnheQiBzw (used as a host) and lJe_rOE2Rjem13F_nyQvKA (used as participant)

Need to turn off the global waiting room settings also it seems

1 Like