How to turn on authentication/cloud recordings

Using this template helps us debug your issues more effectively :slight_smile:

Description
Why is that that for some hosts/accounts, I’m able to use the create a meeting API to turn on “meeting_authentication = true” and auto_recording = “cloud”, but for some hosts, I can’t?
The host that I can: .
The accounts that I can’t completely:

Error
The full error message or issue you are running into.
Trying to send the same API body using m as hosts does not turn on cloud recordings or meeting authentication.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Knowing the endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

Which Endpoint/s?
Knowing the API endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error
    “topic”:“Test ALL zoom (Dom)”,“agenda”:"",“settings”:{“auto_recording”:“cloud”,“approval_type”:2,“join_before_host”:true,“mute_upon_entry”:true,“participant_video”:true,“host_video”:true,“registration_type”:2,“meeting_authentication”:true,“jbh_time”:10,“waiting_room”:false},“start_time”:“2021-05-04T23:08:07Z”,“duration”:12,“type”:2}
    https://api.zoom.us/v2/users/gEI8iIjjTUaVtI48AI7rmw/meetings

and
{“topic”:“Authenticated Zoom Event”,“agenda”:"",“settings”:{“auto_recording”:“none”,“approval_type”:2,“join_before_host”:true,“mute_upon_entry”:false,“participant_video”:true,“host_video”:true,“registration_type”:2,“meeting_authentication”:true,“jbh_time”:10,“waiting_room”:false},“start_time”:“2021-05-04T18:27:13Z”,“duration”:60,“type”:2}
url: https://api.zoom.us/v2/users/DUubK2StTDenMqyP8FGSmg/meetings

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Hi @wesley1,

Thanks for reaching out about this—I was happy to take a closer look.

To that end, I can see that users that you’re running into this issue with seem to be Basic users (no license). I should note that Authentication Profiles/Cloud Recordings settings are only supported for licensed hosts.

If the host user isn’t licensed, then these settings won’t be applied.

This seems to be the issue, but let me know if you’re seeing otherwise or have additional questions about this.

Thanks!
Will