I do not see all the options for adding scope

I am trying to create a server to server app, but when adding the different scopes, I have almost no options.
I need the following:

  • meeting:read:admin (Read meeting details)
  • meeting:write:admin (Create/Update meetings)
  • user:read:admin (Read user details)

Additional scopes are required for certain functionality:

  • Account-level passcode / encryption policies
    • account:read:admin
  • Reports for meetings / webinars
    • dashboard_meetings:read:admin (Business accounts and higher)
    • dashboard_webinars:read:admin (Business accounts and higher)
    • report:read:admin (Pro user and up)
  • Allow recordings to be viewed (zoom | viewrecordings)
    • recording:read:admin
  • Tracking fields (zoom | defaulttrackingfields)
    • tracking_fields:read:admin
  • Recycle licenses (zoom | utmost), (zoom | recycleonjoin)
    • user:write:admin
  • Webinars (zoom | showwebinars), (zoom | webinardefault)
    • webinar:read:admin
    • webinar:write:admin

But I don’t know where I have to add these permissions, whether at role or user level.

Hi @mhadialboukai
Thanks for reaching out to the Zoom Developer Platform, I am happy to help here!
You should have the owner or admin of the account enable certain permissions in your account for you to be able to see those scopes.

By going to
User Management > Roles > Role Settings
Add the permission needed to the role you are working with.

You can refer to this post here:

Hope this helps,

I was able to add the permissions to the role as described. However, I still can’t see the scopes I need to add to the app.

Hi @sandor.antal

I have followed up in another post

1 Like