Server-to-Server OAuth Missing Scopes

We arecreating a Server-to-Server OAuth app in ZOOM for FooEvents Wordpress plugin.
At Scopes section, we are asked to select the following scopes:

View and manage all user meetings (meeting:write:admin)

View and manage all user Webinars (webinar:write:admin)

View all user information (user:read:admin)

But it seems that my account doesn´t have the privileges to see those scopes. We only see Marketplace, Devices, ZOOM IQ and ZOOM Events.

Im attaching some screenshots so you can see my issue (zoom-has-this.png is what i see) and (zoom-need.png is what i need)

Any advice to make my user see the needed scopes?

Thank you

Hi @careteam
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here.
Can you please make sure that the role that you have assigned has the proper permissions?
Make sure to go to the Admin Tab > User management > Roles and click on the role that you have assigned and then click on Role settings and feel free to grab a screenshot of the settings that you have enabled so I can try and replicate the issue

We are having the same issue. Permissions are set correctly, however, still unable to see the scopes we need. Please help.

Hi @sandor.antal
What scopes are you missing?

I am missing the Account and Recording scopes.

Hi @sandor.antal
For this, you have to make sure that the role you have, has the proper permissions enabled.
Head to Admin tab > User management > Roles > Roles settings for the role you are enabling S2S app.

Make sure the Recording management and Account settings, features are enabled for this role


I’m having this issue and I definitely have the permissions set correctly. Was there a resolution to this problem? I’m also missing recordings.

Hi @anthonyg ,

It can vary account by account. What is your user/role designation?

Which exact categories are you looking to add scopes for?


My user/role designation is Owner.

I am creating a server-to-server oauth app with the scopes for: webinars, meetings, users, and recordings

Recordings is the only title not included in the scopes drop down menu of what I’m soiling for…

@anthonyg , I see. The behavior described earlier from other members in this particular thread is separate from what you’re seeing now, but please see the related thread linked for context: