Integration with Salesforce - launch meeting error - not support embedding Zoom resources in iFrames?


I installed the Salesforce-Zoom integration in my Salesforce instance and, when I want to launch the video call from Salesforce the following error message is displayed:

Refused to display ‘’ in a frame because it set ‘X-Frame-Options’ to ‘sameorigin’.

I read another topic where says that It doesn’t support embedding Zoom resources in iFrames anymore.

1- Please, confirm this.
2- Are you planning to fix this bug to show other window inside Salesforce instead of showing the error: “refused to connect”? see the image:
Screenshot 2021-04-12 at 09.49.02


Hey @MEF,

Thank you for reaching out to the Zoom Developer Forum. Please review this historical forum post from our #marketplace-apps category and let me know if it helps to resolve your issue:


Hi @MaxM,

Thank you for your response. That post doesn’t resolve the issue because they suggest installing a chrome extension to allow all pages to be iframed!

I realized that the issue had been solved. This is the way that I am using: When you customize the page layout, you have to choose the “Start Zoom Meeting” quick action instead of choosing the custom button. The quick action works correctly because it is opening the zoom window in a new tab, please see the image:

Thank you again for your response.

Got it, thank you for sharing what worked for you! I’m glad that you found a solution. Let us know if you run into any further issues or questions.