Invalid Access Token for Listing Workspace Reservations

Hello, Trying to call the List Reservations endpoint for workspaces and am getting the following error:
{‘code’: 4711, ‘message’: ‘Invalid access token, does not contain scopes:[workspace:read:list_reservations, workspace:read:list_reservation:admin].’}

Here is the endpoint - "‘’. Have tried with multiple valid workspace ids as well.

I have verified that I have this scope added - “workspace:read:list_reservation:admin”

This is using Oauth server to server, Account Level.

This app works with many other endpoints with no issue. Also have deleted it and re-created it multiple times with the same results. Looked through other discussions and tried published approaches but none worked. Any help is greatly appreciated. Thanks

1 Like

Same exact issue here. Tom, I think if you look close, you’ll see that you have the scope:
workspace:read:list_reservations:admin ← note that reservation’s plural.

@rian, thanks for the reply. I had missed that. Were you able to correct it? Or do you still have the error as well?

I don’t have the list_reservation:admin to select from the scopes available but gives me something to look into now.

No. No dice here. I don’t have either of the two scopes that the API is requesting available:

 message: 'Invalid access token, does not contain scopes:[workspace:read:list_reservations, workspace:read:list_reservation:admin].'

I do have the workspace:read:list_reservations:admin scope, which is the closest thing to what’s being requested.

@t-data For what it’s worth, I tried to file a ticket on this since it appears to just be a broken endpoint, but you can’t do that unless you buy a Super Premium Deluxe Developer Support Contract. So, I fear we’re on our own until someone there notices.

I have the same kind of issue with the POST /zoom_events/events/{eventId}/tickets endpoint, where I also have the required scope. It really seems like some endpoint scope validations are broken on zoom side of things. Here is my post in case you want to watch here for answers as well Create event ticket missing scope "zoom_events:write:ticket"

1 Like

Adding +1 for attention. Issue is definitely the difference in scope naming between what the token gets and what the endpoint expects (plural vs singular).


@elisa.zoom Just trying to reach out here to get some help on this issue. Any direction or other options to try would be very helpful.

1 Like

Hi all, I have the same issue and must create a specific integration. I tried to open a ticket without any luck, so I am in direct contact with Zoom to see if they can investigate the issue.

This is the scope that we need:


This is the available scope (with the syntax error):


This is the error we get due to the situation illustrated above:

{“code”:4711,“message”:“Invalid access token, does not contain scopes:[workspace:read:list_reservation:admin].”}


1 Like

Hello everyone!

With the precious help of @Samantha.Greatorex, the issue has been fixed! :partying_face:

1 Like