'Join Audio by Computer' button grayed out and disabled

I was directed here (by a Zoom chat agent) about a problem I’m seeing with the standard Zoom web-app. Even though I have all audio (and camera) permissions set to allow and I’m using HTTPS, the ‘Join Audio by Computer’ button stays grayed out and not functional. I’m currently seeing this problem when I do a practice session for a recurring webinar (which I’m supposed to host if I can get things working), but I have seen it in non-webinar meetings as well. About a year ago, I was using basically the same setup, and audio worked fairly reliably in both directions.

More details about my setup: Hardware is a Raspberry Pi model 4 (perhaps with a ‘B’ or a ‘B+’ suffix) with 4GB RAM (which was sufficient some months ago). OS is Raspbian 10/buster. Browser is the Raspbian-supplied Chromium, currently 92.0.4515.98. Webcam is a Logitech C920s, ID 046d:0892 (lsusb calls it an OrbiCam), but I have seen similar symptoms using a Logitech USB headset.

When I had audio working with the Zoom web-app around a year ago, I would sometimes see the ‘Join Audio by Computer’ button grayed out and disabled until I went in and set the audio device permissions settings (left end of the URL/address bar) again to allow, even though they were already set to allow. While experimenting a few days ago, once out of several times, when I (re-)set all four permission settings to allow (and did the prompted-for page reload), the button lit up and audio connected just that once. Duplicating the use case several times after that, I never saw the button light up and become enabled. The visual stream from my camera shows up very reliably on my monitor.

The graying out of the button is similar to the description in this thread, although I am using the standard Zoom web-app via HTTPS: Join audio by computer button and camera not working with zoom SDK 1.7.4

While I can’t rule out a PEBCAK issue, I suspect it might be a regression somewhere in the stack, because basically the same functionality worked some months ago. I’d be grateful for suggestions to remedy or work around the problem from my side and/or try to get it fixed if it is a bug.

Thanks,

Robert

Bump with a bit more information. I tried it again today but with a USB headset or a USB-audio adapter plugged in. The first time I attempted to join a meeting with the headset plugged in, the ‘Join audio by computer’ button lit up and things were looking good. Then, I got an “Aw, snap. Something went wrong.” message. Any suggestions that might help get this to work?