Joining Fail with Error Code 1

Hi @tommy !
Yes I’m using Node app to generate signature which is running on localhost:4000

Hey @tommy Can I get help in this issue? Its urgent.

Hey @vikasphp.shinedezign, I promise I am human :wink:

Were you able to get it running?

Can you try using the updated signature code:

https://marketplace.zoom.us/docs/sdk/native-sdks/web/essential/signature

What are you passing in for the role when trying to join webinar? Starting a webinar from the Web SDK (role 1) is not supported.

Thanks,
Tommy

Hey @azaz.nuces,

I noticed you have a Free Basic account. You need at least a Pro account to use the Web SDK.

Please upgrade and try again.

Thanks,
Tommy

Hi Tommy,

Thank for your reply :slight_smile:

Q. Your connection has timed out and you cannot join the webinar. Verify your network connectivity and try again.

**Reply: **Your app and for the attendee, I used web SDK…and amusing role 0 there…but getting this error

" Your connection has timed out and you cannot join the webinar. Verify your network connectivity and try again.

**Note: **Internet speed also so good and there is no firewall.

Thank you

Hey @vikasphp.shinedezign,

Happe to help! :slight_smile:

Are you also passing in the userEmail field for the attendee? This is required for joining webinar.

Thanks,
Tommy

Hi Tommy
Yes I used my same email vikasphp.shinedezign@gmail.com

thank you

Hi @vikasphp.shinedezign,

When typing in the meeting ID make sure to remove the slashes when you submit the meeting ID. For example MeetingID 123-45-678 -> 12345678.

If that doesn’t work, can you DM me your account number and email used for marketplace?

Hi Michael_Purnell
Here is email id: vikasphp.shinedezign@gmail.com

Account ID: 113113921

Yes, we use meeting id without the hyphen.

Here is code we using:

var meetConfig = {
apiKey: API_KEY,
apiSecret: API_SECRET,
meetingNumber: parseInt(document.getElementById(‘meeting_number’).value),
userName: document.getElementById(‘display_name’).value,
passWord: “”,
leaveUrl: “https://zoom.us/”,
role: 0
};

   var signature = ZoomMtg.generateSignature({
       meetingNumber: meetConfig.meetingNumber,
       apiKey: meetConfig.apiKey,
       apiSecret: meetConfig.apiSecret,
       role: meetConfig.role,
       success: function(res){
           console.log(res.result);
       }
   });

   ZoomMtg.init({
       leaveUrl: '[https://zoom.us/](https://www.google.com/url?q=https://zoom.us/&sa=D&source=hangouts&ust=1585974982924000&usg=AFQjCNGjcBWwjztvEqfDVpqOuO8W7G021w)',
       isSupportAV: true,

success: function () {
ZoomMtg.join(
{
meetingNumber: meetConfig.meetingNumber,
userName: meetConfig.userName,
signature: signature,
apiKey: meetConfig.apiKey,
userEmail: ‘vikasphp.shinedezign@gmail.com’,
passWord: meetConfig.passWord,
success: function(res){
('#nav-tool,#dialog-join,#wc-footer-left').hide(); (’.presentation,.footer-button__button,.more-button’).hide();

setTimeout(function(){ $("#dialog-join").show(); }, 5000);
console.log(‘join meeting success’);
},
error: function(res) {
console.log(res);
}
}
);
},
error: function(res) {
console.log(res);
}
});

Thank you

Hey @vikasphp.shinedezign,

Please see the following Web SDK update if you have not already:

We are working to get the Zoom Web Client and Zoom Web SDK back online. Please keep up with our status page for detailed updates: status.zoom.us


The best workaround is to use the Zoom Desktop / Mobile app.

Just include the Zoom meeting join url (https://zoom.us/j/meetingID) on your site rather than showing the websdk / iframe. Clicking on the join url will open the Zoom meeting in the Zoom app.

Apologies for the inconvenience,
Tommy

Hi Tommy,

Today I have checked implemented code stop working please let me know when will start? Because I have already set some meetings with my client.

Thank you

still waiting for your response.

thank you

Hey @vikasphp.shinedezign,

The Zoom Web Client is back up.

Please see latest update here for the Web SDK:

https://marketplace.zoom.us/docs/guides/getting-started/stay-up-to-date/upcoming-changes/web-sdk

Thanks,
Tommy

Hello
Im having the same issue , I read some comment here from oct 19
that says its only available to “developer” type of an account

I want to implement zoom in my website for my users to user while they attend to zoom meeting , is it possible ? how ?
thank you

HI @aviram7168,

You can use our WebSDK to implement Zoom meetings/webinars within your website. https://marketplace.zoom.us/docs/sdk/native-sdks/web. Also if you need to embed within a website then you can follow this thread - Embed Zoom into Website

Hi @Michael_Purnell
sorry i wasnt clear enough,

I an using the WebSDK with

ZoomMtg.setZoomJSLib('https://dmogdx0jrul3u.cloudfront.net/1.7.4/lib', '/av'); 

and JWT Api

and it works perfectly for meetings that Im hosting ,
but if I want to connect to other meeting its firing me “1” error code on “join”.

why is that?
beacuse the host is not developer ?
am I doing something wrong ?

thanks

Hey @aviram7168,

For joining other meetings outside of your Zoom account, make sure you are setting the role to 0.

Thanks,
Tommy

Hai i am able to create the meeting and join as host ,but when i try to join as attendee getting this error

  1. errorCode: 1
  2. errorMessage: “Fail to join the meeting.”
  3. method: “join”
  4. result: “The current sdk version doesn’t support register meeting/webinar, please upgrade to the latest version.”
  5. status: false

For the above error this is the code i have written i don’t want the attendees to register for meeting how should
“host_video”: true,
“participant_video”: true,
“cn_meeting”: false,
“in_meeting”: false,
“join_before_host”: true,
“mute_upon_entry”: true,
“watermark”: false,
“use_pmi”: false,
“approval_type”: 1,
“registration_type”: 0,
“audio”:“voip”,
“enforce_login”: false,
“enforce_login_domains”: “”,
“alternative_hosts”: “”,
“registrants_email_notification”: false

Hey @pavanschoovideos,

Please see my post here:

Thanks,
Tommy