Joining meeting timeout from Web SDK

I’m using the WebSDK to join a Zoom meeting but navigating on the join meeting link we get this error intermittently. Sometimes joining the meeting is successful without any issues but some times this error comes up. There are no network issues on the client end.

“Joining meeting timeout” - “Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again”


“Joining meeting timeout” - “Your connection has timed out and you cannot join the meeting. Verify your network connectivity and try again”

Which version?
We are using the WebSDK version 1.7.10.

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to the join meeting link generated usin the meetingId, signature & API key.
  2. See error


Device (please complete the following information):

  • Browser: Chrome, latest version.
1 Like

Hey @haseeb

Thanks for posting on the Zoom Devforum! I am still learning, but I will try my best to help answer your question. :slightly_smiling_face:

Checkout these related threads that may have the answer you are looking for:

If these threads did not help, please let us know by replying back here and someone from the Developer Relations team will get back to you shortly.


The recommended solutions seem related to an incident which was stopping users from joinning the meeting. Since there is no such incident reported at this time, this does not solve my problem as we are still facing the issue intermittently.


I started having today the same issue with my meetings as well.
I’ve been able to reproduce this issue in Safari will in Chrome looks like it’s working fine (the issue was reported by several of my clients, I am not sure what browser they were using).

I was able to catch the following error in the js console:
[Error] Failed to load resource: the server responded with a status of 403 () (, line 0)

Thanks in advance for your help.


I think it’s an intermittent error. Our customers have reported that the issue occurs for them but if they try joining the meeting again it sometimes works. Waiting for someone from Zoom to confirm what the issue could be.

1 Like

Facing the same issue, this error started appearing today


1 Like

Facing this issue since morning please look into it as we’ve several clients using it


We’ve got similar isuue. Same alert but the ZoomMtg.join() method doesn’t trigger the error callback (which it does eg. if you put wrong meeting id).

One thing I noticed is websocket messages - there are some errors apparently (invalid version, invalid parameters but no details):

We’re using WebSDK 1.8.6.


since today, we’re facing the same issue with all of our accounts. We’re using SDK Version 1.8.6.

1 Like

Hi @haseeb @alexander.brotzge @islam.daanish @yasmin @konrad @ronen.landesman

We are investigating the issue and will provide an update as soon as we can. (CS-2912)



@will.zoom @haseeb @alexander.brotzge @yasmin @konrad @ronen.landesman
Issue resolved by upgrading webSDK to 1.8.6

1 Like

@islam.daanish some users have reported the issue with 1.8.6 as well. Also, there was no prior notice of previous versions being totally broken. We cannot migrate to 1.8.6 so quickly. Hopefully we’ll get an answer from @will.zoom soon so we can decide on our further course of action.

Yes I updated from 1.7.1 to 1.8.6 but still the same issue.
Also when we are able to connect (1/10) it connects two times the same user…
Not sure if it’s related to this issue

1 Like

Hi @will.zoom still waiting for a reply. Please let us know if this is going to be resolved or is the solution migrating to a newer version of the SDK. We are in a different timezone than the Zoom support team & will appreciate if we can get a response today from you guys so we can resolve this issue for our customers during our working hours tomorrow.

Hey @haseeb , @ptlagency ,

We are still investigating the issue, and will provide an update as soon as possible.


Hey @haseeb , @ronen.landesman , @ptlagency , @alexander.brotzge , @islam.daanish ,

This issue should now be fixed. Please let us know if you continue to have trouble. :slight_smile:


Follow the problem

We have the same issue, it was showing up in version 1.7.9, we updated to 1.8.6 and still the same issue

Hi zoom guys! I am facing the same error with version 1.8.6 all the time, is there any solution to this issue?

It seems we still have the same issue. 1.8.6, trying to join a running personal meeting, from website using WebSDK.