Just started getting 500 response from createUser POST

Today we began getting a 500 Internal Server error html page when POSTing to /users to create a new user. We haven’t changed code in months and successfully were creating users 4 days ago.

POST to
https://api.zoom.us/v2/users/?access_token=

Request:
{“action”:“custCreate”,“user_info”:{“account_id”:null,“cms_user_id”:null,“created_at”:null,“dept”:null,“email”:“some@email”,“first_name”:“somefirst”,“host_key”:null,“id”:null,“jid”:null,“language”:null,“last_client_version”:null,“last_long_time”:null,“last_name”:“somelastname”,“password”:null,“phone_country”:null,“phone_number”:null,“pic_url”:null,“pmi”:0,“private_meeting_url”:null,“status”:null,“timezone”:null,“type”:2,“use_pmi”:false,“vanity_url”:null,“verified”:0}}

TIA,

Will

Looking like this is a dup of similar issue that just got reported in the ‘users’ subcategory (where I should have put this, honestly).

If you remove empty/null fields, it appears to work. But that’s a validation change on zoom’s end in the last day ?

@whughes I want to say this has been the behavior for quite some time now as I recall running into this null issue months/years ago. But I would need to double check with our API team for this specific endpoint. With that being said, I’m not sure where all your fields are coming from. The create meeting api only expects/accepts a subset of these fields. But in general, it’s best to omit fields that don’t have an explicit value.

According to the feedback in the other Forum post ( Creating users through the REST endpoint failing consistently from some machines - API and Webhooks / Users and Groups - Zoom Developer Forum ) this is a NEW issue. We were able to create new users up until Oct 11, and then ‘poof’ just Error 500.

This is new behavior, and if Zoom is going to enforce a new schema / parameters, then it must be announced and can’t be dropped on customers randomly.

Can we get some commitment from Zoom to revert this change or comment on it?

1 Like

We haven’t changed code in months and created users 4 days ago. As for null fields, either declare in the API that the fields cannot have null or not. Regardless, you can’t throw 500s on it.

1 Like

@whughes @jjumper i totally understand the frustration and I agree. Any new changes to the api (regardless of what they may be) should be clearly documented with proper error codes. I will reach out to our API team.

1 Like

Oh, what’s more, this error occurs BEFORE any token checks occur. So I can test this without a token.
That’s really odd behavior imo. Totally reproducible from reqbin.com at this very moment.

thanks! appreciate the quick responses!

Anything on this? (for monday really)

This was reported FOUR days ago - can we please get a response?!

@whughes @jjumper I have made the request with our API team and I’m awaiting their response. Apologies for the delay and I appreciate your patience!

@whughes @jjumper while we wait for an official comment from the API team, is it accurate to say that removing null fields unblocks this issue for you?

Our situation wasn’t a null field in our payload; for us it seems like it would fail on any field that is not part of the documented fields null or not.

The 500 response seems a little odd, it seems like you should be able to handle it and return an error with an invalid field message. If the api had returned a tangible response and error code; other then 500 and no message it could have cut hours off refactoring of code because I just didn’t know why & it had worked for over 2 years already.

I think the bigger concern is changing the API without publishing documentation on how it works soon enough before the change happens to the API. This is the second time this has happened to us with the zoom api. Last was the limit of 3 attempts to Register per meeting, zoom didn’t post anything about the change till 2 weeks after it was implemented(on a weekend!) and it took more then a month for your support to even give back an answer!

success
{“action”:“custCreate”,
“user_info”:{
“first_name”:“Test”,
“last_name”:“New User 102”,
“email":"virtual_11111111@domain.com”,
“type”:“1”}}

fails, worked for the last 2 years until Oct 12th 4am Pacific
{“action”:“custCreate”,
“user_info”:{
“first_name”:“Test”,
“last_name”:“New User 102”,
“people_id”:“11111111”,
“email":"virtual_11111111@domain.com”,
“type”:“1”}}

2 Likes

Probably, as that’s what worked in reqbin but not something we can implement easily or timely. That’d be a full production release on our end. Yeah, obviously same for zoom but in this case it would be reverting the release you evidently slipped in without informing anyone or even publishing it in your changelog.

Hello friends,

We’ve encountered the same exact issue with Zoom API when trying to create new users.
Getting error 500 with this payload

2022-10-20 08:35:32.20 (GMT+0) - import.php POST
{“action”:“custCreate”,“user_info”:{“email”:“xxxxxxx@xxxxxx.ac.il”,“type”:2,“password”:“xxxxxx”,“first_name”:“xxxxxx”,“last_name”:“xxxxx”,“other_details”:{“courseid”:“xxxxx”}}} /users/ (HTTP 500)

Awaiting for ZOOM API immediate fix or workaround.

Best Regards,
Yuval.

1 Like

Hello all,
Thank you for your patience while we investigated this. Our team will be releasing a fix this weekend.

Best,
Brandon