JWT App is not working on multiple Zoom accounts

Hi Tommy / Staff,

I’m wondering if this is the issue I’m running into with our account as well. I am able to see recordings only on my account, but not on any sub accounts and I get an error when trying to get the list of accounts ( [code] => 124, [message] => Invalid access token.).

Account #7001507720

Thank you for your assistance!

Hey @MNMSA_Webmaster,

It appears you do not have a Master account. Which API are you trying to use?

Thanks,
Tommy

Hey @tommy,

We’re trying to use https://api.zoom.us/v2/accounts/me/recordings/users/<user_id>/recordings

It works for our own account, but not for the sub accounts on our account. I may be making a bad assumption: My assumption was, a master account was any account that had sub accounts. If that’s not the case, then I guess my question would be, what does it take to have a master account, or is there a way I can access the cloud recordings via the API as opposed to having to get every user to setup a key for me and/or do it via the cloud dashboard (the dashboard does allow me to see all my sub accounts recordings under Account Management->Recording Management.)

Hey @MNMSA_Webmaster,

This is correct, however to get users recordings apart of your own Zoom account, you can use the Get Users Recordings Endpoint.

Try that and let me know if it works. :slight_smile:

Thanks,
Tommy

@MNMSA_Webmaster
I am getting the message {“code”:124,“message”:“The Token can’t be used before Thu Mar 04 18:50:36 UTC 2021.”}

Hey @jblake,

Thank you for reaching out to the Zoom Developer Forum. Please submit a new forum post with information on how you are generating the JWT token as well as steps to reproduce the issue you’re seeing.

Thanks,
Max

It is working now thank you!

Glad you were able to figure it out, @jblake! :100:

Hi,
I have the same issue described above.
I’m receiving this response { “code”:124,“message”:“Access token is expired.”}

Any one know how can i fix it?

Best Regards
Rafael

Hi @zoom.hyper.01,

Can you try generating a new token with a longer expiration time? You can set the expiration time for a JWT token by following the steps at the bottom of the first post in this thread:

Let us know if this helps,
Will

I’m having a similar problem with my JWT API settings. One of my colleagues already created this and when I try to use it to connect to my wordpress site I get this message: “Webinar plan is missing. You must subscribe to the webinar plan and enable webinaes for this user in order to perform this action:###” I have a webinar plan on our Zoom account and I do not understand what I need to do to fix this issue… I tried deactivating and reactivating the JWT App but it didn’t change anything.

Hi @nep,

Have you ensured that the user under whom the request is being made (the user ID or email being passed in the request URL) has a webinar license assigned?

Thanks,
Will