MacOS getBOMeetingController always returns nil even when in meeting

I’m trying to create a breakout room as the meeting host using the MacOS SDK. I wait for ZoomSDKMeetingServiceDelegate to show state == ZoomSDKMeetingStatus_InMeeting
Then call this code:

ZoomSDKNewBreakoutRoomController*  breakoutRoomController = [[[ZoomSDK sharedSDK] getMeetingService] getNewBreakoutRoomController];
 ZoomSDKBOMeetingCreator* boMc = [breakoutRoomController getBOMeetingCreator];

I observe that boMc Is always nil.

NSString* boId = [boMc createBOWithBOName:@"Test BO"];
NSLog(@"BO MeetingId %@", boId);

I can see that Breakout Rooms are enabled for example:

NSLog(@"BO Enabled %@", breakoutRoomController.isBOEnable ? @"YES" : @"NO");

Shows output of BO Enabled YES

I’ve checked my account settings and using the standard zoom app I can create a breakout room.

Which version?
[[ZoomSDK sharedSDK] getSDKVersionNumber} returns: 5.0.1 (24433.0616)

To Reproduce(If applicable)
See above

If applicable, add screenshots to help explain your problem.

Device (please complete the following information):

  • Device Spec: Mac
  • OS: MacOS
  • Version 10.15.5
  • XCode Version: 10.3 (10G8)

Hi @DevGuy5678,

Thanks for using Zoom SDK and pardon the late response. We have tried to use the code you have provided and tried to reproduce this with the demo app and we are not getting nil from boMc. Could you have a try with our demo app and if the issue is reproducible, could you provide the steps to reproduce?