`meeting.participant_joined` not firing

Description
This Webhook is not firing: meeting.participant_joined

Error
No error message

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Just testing our App now, called “Audience Republic” (we’ve dropped the “Dev”). Could not see the Webhooks activated for joining and leaving. The Meeting ID was 960 4750 9976.

I even re-installed the App and tried again with Meeting 931 0368 9205. But Webhooks not being picked up still.

Hi @chrismurrph,

Thanks for reaching out, and happy to help.

Can you confirm that your endpoint is publicly accessible and returns a 200OK response? In checking the endpoint associated with the app you provided, it looks like it’s currently returning a 500 error:

    "status": 500,
    "message": "The server encountered an unexpected condition which prevented it from fulfilling the request",
    "time": "2021-02-23T17:46:05.932Z"

Let me know if you can double check the endpoints you’ve specified for your app’s webhook event subscriptions:

Thanks,
Will

Thanks for testing that for me. Sorry that error message was caused by an assert in the code. It is now a bit more friendly. It is now possible to post anything (I guess) and 200 will be returned. Can I expect the “meeting.participant_joined” event to happen just as someone enters the meeting? I’m still not seeing that even though I’m joining the meeting as host then as another user on another machine. This could of course be due to the temporary blacklisting you do. I’ll try again in the morning.

Hi @chrismurrph,

Yes, this should be near real time—or within a minute or two at most. Please let me know if you’re still not seeing the event when you check back.

Thanks,
Will

It sounds like just starting a meeting should be enough, because then I automatically enter as host. I did that this morning for Meeting ID 938 8203 6175 and saw nothing in the logs, waiting for a few minutes. But I verified that the WebHooks endpoint is receiving messages by doing a POST to it - I saw that in the logs. For this POST I am definitely using the right endpoint because it is the the one described in the Features tab as: “Destination URL of the event notification. For testing in your local environment.” The only conclusion I can reach is that Zoom is not calling the WebHook endpoint when the ‘meeting.participant_joined’ event is triggered. I’ll be able to see something in the logs no matter how it is called. For instance when I manually test the event used is ‘just.testing’. So you could manually POST and I would be able to see ‘whatever.you_put’ in the logs.

Did you just trigger the endpoint, as in just now (this forum message creation time)?
A GET at the destination URL will trigger a 500 response. Could that be a problem? (I doubt it, but have to look at every possibility now).
Okay I think I’m just creating noise here. There happened to be a POST to the wrong endpoint that was rejected with a 500.

Hey @chrismurrph,

Thanks for sharing these details, and sorry this is still an issue—I’m sure this is frustrating. A couple more things I’d like to ask you to try: can you please regenerate the publishable URL for your app and reinstall using the new URL?:
image

Next, can you try replacing your endpoints (temporarily) with an endpoint from something like https://requestbin.com/ or similar? I’d like to rule out that there isn’t something we’re not catching with your existing endpoint.

If you update the endpoint for testing, please reinstall the app once more before starting a test meeting.

If none of these do the trick, let me know—I’m happy to private message you and set up some time to troubleshoot this over a Zoom call.

Thanks,
Will