Meeting start url asking for login

This just started happening. When the start url is clicked, this message shows up:

“if you are the meeting host, sign in to start the meeting”

Hey @fred

Thanks for posting on the Zoom Devforum! I am still learning, but I will try my best to help answer your question. :slightly_smiling_face:

Checkout this related thread that may have the answer you are looking for:

If this thread did not help, please let us know by replying back here and someone from the Developer Relations team will get back to you shortly.


The thread isn’t relevant.


I just started to see that today as well.

The meeting is started in the desktop client, then when someone clicks the link to join, they get that notice instead of just joining as an Attendee.

I think this is a new bug.

FWIW, I only see this happening on my professional Zoom account, not my personal. I’ll compare settings.

Here’s what I found. If you look at the meeting URL, if it has an “s” where the “j” is below, then it displays this behaviour.

I’m not sure what setting changes it, but something changed that for me, now I can get in without that blocking screen.

I think it might have to do with the “Enable join before host”.

Hey @bklocek, @fred,

Are you still seeing this issue?

Make sure if you are using the start_url, that it is not expired.


Yes at times. It also happens with an attended join url where it will ask for a password. Not always.

Hey @fred,

Are you able to reproduce this issue, or is it random? If you are able to reproduce it, please provide the steps. :slight_smile:


I am facing with the same issue as @fred. When the start url is clicked, this message shows up:

“if you are the meeting host, sign in to start the meeting”.
I am facing a lot of problem with this issue. Kindly solve this as soon as possible.
Faisal Khan.

Hey @faisal,

Can you confirm the start_url is not expired? It only lasts 2 hours, unless you regenerate it by calling the Get Meeting API.


Oh, I missed this. Is this documented somewhere? If it’s the case, we can adjust.

Hey @fred,

This is documented under the Create Meeting endpoint:

Let us know if you have any questions!


1 Like

Thank you. That makes sense. We’ll make sure we only fetch and communicate start_urls no earlier than 2 hours before the meeting starts then.

Hey @fred,

Glad we could help clarify!


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.