MobileRTCAuth Service not triggering onMobileRTCAuthReturn and getAuthService always return nil

Description
I am integrating Zoom SDK in iOS app and for testing purpose I have registered for basic plan as it give me 60 days trial period. I created app on zoom and got my sdkKey, sdkSecret and JWT which is I am using in the demo project given with Zoom SDK as well as my own sample project.
The issue is that the demo project with Zoom SDK is working fine as it is triggering onMobileRTCAuthReturn and also getAuthService instances are getting value and I am able to start meeting after sign in in the demo project. But in my sample project I am unable to get any of these scenario working. First after Auth statements onMobileRTCAuthReturn is not triggering (if I pass “” to key and secret of auth then only onMobileRTCAuthReturn is triggered). Second getAuthService always returns a nil object. I have seen some posts on form regarding these issues that says the domain need to set and main thread need to set. I have done all of them. But my sample project is not at all working. I am a developer so please reply me as soon as possible. Thanks.

Which version?
ios-mobilertc-all-4.6.15084.0206-n.zip
that I got from this link: https://github.com/zoom/zoom-sdk-ios/releases/tag/v4.6.15084.0206

Screenshots

Hi rj1234ios,

Thanks for using Zoom SDK. If the onMobileRTCAuthReturn is not triggered, it’s probably the MobileRTCAuthDelegate is not imported. Our demo app has the exact same implementation as you shown in the screenshot, please refer to the implementation in our demo app and see if it helps: rj1234ios

BTW, you only need to pass either clientKey&&clientSecret or JWT token for authentication. It is recommended to use JWT token.

Thanks!

Hi Carson,
Thanks for reply. I forgot to add MobileRTCAuthDelegate in my viewcontroller, I have added now. But Please consider that:
“When I do not add ClientKey&Secret to authService in
MobileRTCAuthService *authService = [[MobileRTC sharedRTC] getAuthService];
then only onMobileRTCAuthReturn triggers and the statement
NSLog(@“onMobileRTCAuthReturn %d”, returnValue);
prints :: onMobileRTCAuthReturn 1
No matter MobileRTCAuthDelegate is added or not.”
If I add proper ClientKey&Secret or JWT to authService it never triggers onMobileRTCAuthReturn.
It seems like it is not authenticating my app.

Hi Carson,
I am also getting same problem. It works perfectly fine on demo app. But when I started integrating in my app. getAuthService is returning nil value.

Hey there,
I feel glad to notify you all that my authentication problem is solved. I added the the delegate that Carson mentioned and I played with ClientKey&Secret. I changed the ClientKy&Secret and compiled and run my app and then again added the right Key&Secret and it worked. Now it is authenticating the app and onMobileRTCAuthReturn is triggering each time, also getAuthService is not more returning nil now. Thanks for your consideration team Zoom. Happy Zooming !!!

Hi rj1234ios,

Thanks for sharing the great news! Glad to hear that the problem has been resolved. Happy Zooming! :slight_smile:

Hi vaneet.modgill,

Thanks for using Zoom SDK. Could you provide more details on the issue you are facing? @rj1234ios has shared his experience dealing with this kind question above, does his experience helpful for you?

Thanks!