MobileRTCAuthService not responding

Hi, we have an Ionic/cordova app for ios.

we are using Zoom for meetings in our websites, while one of the website has the functionality to create meeting. And now we are trying to implement zoom functionality only for joining meetings in our app.

To implement it we need to create a plugin to integrate with angular.

For the record, I’m not an ios programmer.

When I call [authService sdkAuth]

with empty  clientKey and  clientSecret the callback function  onMobileRTCAuthReturn getting called while the returnValue is error. (a good sign)

The problem I have is that when i’m calling [authService sdkAuth] while my 

clientKey and  clientSecret are initiated with real values, the callback function 

onMobileRTCAuthReturn not getting executed.

Any ideas what should i do?

Do you know about any zoom cordova plugin that might exist somewhere?

Have you set the domain before calling “sdkAuth”? BTW, suggest that you refer to our MobileRTCSample, which will make you understand clearly our iOS mobileRTC how to work.



I’ve set the domain, same problem.

Also, downloaded the sample app that works fine with our zoom parameters.

I think that I’m skipping some phase.

my code looks something like this:

if (authService){

            authService.delegate = self;

            [authService logoutRTC];

            authService.clientKey = MyKey;

            authService.clientSecret = MyClientSecret;


            [authService sdkAuth];


        MobileRTCMeetingService *ms = [[MobileRTC sharedRTC] getMeetingService];

        if (ms){…

Am I missing something between the sdkAuth and _MobileRTCMeetingService _initialization?

Have you met this issue with our MobileRTCSample? You can try this case in sample project at first, I think that it will make you understand how MobileRTC to work easier.



Yes I did.

the sample works fine without changing anything.

But when I add the method (void)sdkAuth in  AppDelegate.m

 the lines  in bold:


- (void)sdkAuth



    MobileRTCAuthService *authService = [[MobileRTC sharedRTC] getAuthService];

    if (authService)


        authService.delegate = self;


        [authService logoutRTC];


        authService.clientKey = @“clientKey”;

        authService.clientSecret = @“clientSecret”;


        [authService sdkAuth];

        // Trying to initiate MobileRTCMeetingService right after authentication.

        MobileRTCMeetingService *ms = [[MobileRTC sharedRTC] getMeetingService];

        if (ms) {




the ms will be nil, and I think it’s because I have to wait for the callback method  onMobileRTCAuthReturn to be executed and that the  returnValue will be  MobileRTCAuthError_Success.

the original code works fine because the initiating of  MobileRTCMeetingService is executed after

pressing Join a Meeting button.

Am i correct?

If so, how do the sample app achieve this “waiting” in the original code? 

Thank you very much!!


You cannot get the instance of meeting service before SDK auth successfully. Our mobileRTC just can be useful after SDK auth successfully.

What I mean is that you just can get instance of meeting service after you received callback method "

  • (void)onMobileRTCAuthReturn:(MobileRTCAuthError)returnValue


Thanks, my problem was that i used a background thread what caused the callback not to execute. Don’t really know why but now it works.

Thank u very much!!



1 Like

Sorry, MobileRTC does not support to handle callback functions in another thread except main thread.

Hi, i have the same problem with iOS swift implementation, @Izhar_Laufer how do you solve the problem?, auth function and delegate are in appDelegate.swift so, any ideas why is not running at didFinishLaunchingWithOptions?

Hi operea,

Thanks for using Zoom SDK. May I inquire more details on the issue you are facing? Could you provide the following info so that we can further help you?

A clear and concise description of what the question is.

Which version?
Knowing the version can help us to identify your issue faster.

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

If applicable, add screenshots to help explain your problem.

Smartphone (please complete the following information):

  • Device: [e.g. iPhone6]
  • OS: [e.g. iOS8.1]
  • Version [e.g. 22]

Additional context
Add any other context about the problem here.


Hi @carson.zoom,

I have some trouble with SDK (v4.4.55968.0904) auth implementation, for iOS swift project, this is the actual code that I wrote following the documentation for iOS integration.

Problem is in function onMobileRTCAuthReturn, this function is not running, or auth is not finish correctly.

Nothing of this appear in debug console, because the function is not running, because auth process has an unknown problem. I’m also debugging on iPhone 6 (12.4.1)
This is all the debug console shows, as you can see nothing in function onMobileRTCAuthReturn appears.

And this is what I have no idea what is happening, when I change kSDKAppKey & kSDKAppSecret to “” as the example, function run normally.

Is the same code, same auth implementation, only different key & secret values.
I want to know if is implementation problem or if I miss some configuration at SDK console level, please help me to solve and correct implement SDK.

Sorry for the image, reply only allow me to attach one capture.

Hi operea,

Thanks for the info and the screenshot. It is very strange that the sdkAuth method only works when the key & secrets are empty. I tried the same operations with our demo app available on the Github and I am not able to reproduce this. Could you reproduce this issue with our demo app? If yes, could you let me know the steps to reproduce this?

What is the XCode version are you using?

BTW, your full SDK key & secret are shown in the screenshot. I have removed your screenshot to protect your credentials. I don’t know if anyone else sees this screenshot before I remove it, so please revoke your key & secret by visiting the marketplace and regenerate the pairs.


Yeah, I check this in demo app, with same SDK key & secret, demo app return error 2 (because the remove you done before), and check again in my app integration, with the same result (auth function not running), then with new SDK key & secret with demo app return error 0 (auth success) and my app without behavior changes, also notice the demo language is objC, and my app language is swift, this affect SDK behavior?, SDK integration is not presenting problems because of language, have i missing some configuration parameter in AppDelegate maybe?, the documentation do not mention it, also Xcode not show build time issues. Xcode version is 10.3.

Hi operea,

Thanks for the reply. I only removed your screenshot in your previous reply that shows your key & secret, I did not do anything to your key & secret. Our iOS SDK works with both Objc and Swift, we have a lot of users who are using Swift. There is no language-specific configuration needed. As long as you following the instructions mentioned in the doc, our SDK should work.

We do not have Xcode 11 support yet so using Xcode 11 to build might cause some issues. Since you are using Xcode 10.3, then we can cross out the possibility of the Xcode version is the root cause of the issue you were facing.

Not sure if I understand correctly, is the issue solved? Please feel free to let me know if you have any other questions.


Thanks @carson.zoom,

Issue is not solved yet, i keep trying to fix it checking both the demo and the integration code.

With Xcode not show build times issues, i mean that dependencies are linked correctly to the project, and this is why I think I miss something in config, yet I keep looking for the answer.

Hi operea,

Thanks for the reply. If you are following the following guidances in the doc:

Then you should be able to pass SDK auth. When I was looking at your code in your screenshot and I didn’t see any issues. Please let us know if you could provide any other info that could help us to further investigate in this issue.