No audio after waiting list

Description
User is unable to join audio stream if they come from a waiting room

Which version?
websdk 1.8.6

To Reproduce
Steps to reproduce the behavior:
0. Enable Waiting room for zoom conference

  1. Open Browser A as host
  2. Open Browser B as participant
  3. A sees notification that B is in the waiting room
  4. A clicks Admit
  5. B is admitted into the conference without audio
  6. B refreshes the window
  7. B sees “Join Audio by Computer” button
  8. B clicks the button and is able to hear

If A clicks “But in waiting room” and repeats the steps above, user B again looses “Join Audio by Computer” button and is not able to hear

** Note **
In either case, user is able to join audio if they click the small “Join Audio” button the on the bottom left but that button is small and not always obvious to the user

Screenshots
If applicable, add screenshots to help explain your problem.

Device (please complete the following information):

  • OS: Windows/Linux
  • Browser: Chrome

Hey @ilya1,

Thank you for reaching out to the Zoom Developer Forum. I just have a couple of questions to get us started:

  1. What do you mean by

If A clicks “But in waiting room”

  1. This happens when both users are on the Web SDK, correct? Does this happen when one of them is using the client too?

Thanks,
Max

Thanks for quick response

  1. Sorry, misspelling. It should be “Put in Waiting Room”
  2. Yes, both users are in Web SDK. My app requires both admin and uses to use the embedded version

Also, i will note this started happening with 1.8.x upgrade. It worked fine in previous version

hi @MaxM any updates? Unfortunately, I can’t even rollback to previous version since audio for sub 1.8 versions is turned off.

Also, wanted to add one more interesting note. Zoom does recognize that speaker is talking because it shows a small not on the right “Talking: {name of speaker}” like in this image

Hey @ilya1,

It seems this step is causing the issue. What is the use case for user B refreshing the window?

Thanks,
Tommy

Hi Tommy, now that is not the problem. The problem is that users are not able to hear the speaker. However, I noticed that if they refresh the window, they are able to hear.

Hey @ilya1 ,

That is strange. Can you confirm the users are on version 1.8.5+ of the Web SDK, they have allowed the browser to access their microphone, and that your site is served via https?

Thanks,
Tommy

Yup, confirmed. We are on 1.8.6 using various browsers (Chome, Firefox). Audio is enabled (when the “Join with Audio” button appears it does work correctly.

Hey @ilya1 ,

Are you still seeing this issue? Can you please try updating to the latest version, 1.9.0?

Thanks,
Tommy

Hi Tommy

Just tried upgrading to 1.9.0. Unfortunately, same problem still persists :frowning:

Hey @ilya1 ,

Sorry to hear that. Can you please provide a video of the issue? We are having a hard time reproducing, and do not have any additional reports of this issue.

Thanks,
Tommy

Hi Tommy, I can give you access to our QA environment with instructions on how to reproduce it. Can I send you a direct message/email?

Hey @ilya1 ,

Yes, please email the info and a link to this thread to developersupport@zoom.us. :slight_smile:

Thanks,
Tommy