Not getting user email in zoom app for participant joined and other meeting related webhooks

In our app we are consuming zoom meeting webhooks. We have enabled participant joined meeting webhook and expect user email in payload for already logged in users but for some users we are not getting them in payload,
Although the user is logged in.

Webhook events

  1. Participant/host joined meeting
  2. Participant/host left meeting
  3. Participant joined waiting room
  4. Participant admitted meeting

Steps to reproduce the behavior:

  1. Create zoom meeting.
  2. Join zoom meeting with another user which is signed in on zoom app.
  3. Check if zoom email is visible in webhook payload.

Hi @zawar.ahmed

Thanks for reaching out to the Zoom Developer Forum.
Can you confirm that not only the users are logged in but also the registration is required?

Reference the following link:


This is blocker for our application flows as only zoom emails were available as identifier for us. We expect email to be present in webhook so that we can compare it with our existing user data and check if the participant is the one which we were expecting on call or not.
We need to get it working or have some workaround it.
Can you please look into this on urgent bases? Our whole application flow depends on it.

Also please let me know how can we enable registrant from console.
I am getting this on post registrant api Registration has not been enabled for this meeting: 1234578

Hi @zawar.ahmed

When you say “enable registrant from console” do you refer to the Web Portal or are you doing this via API?

yes, via web portal and api both

Hi @zawar.ahmed

You can enable registration required both via Web portal and API
When you schedule a meeting via Web Portal, you will see an option to Require registration:

And Via API you will need to pass the field “approval_type” in your settings when making your request:

Hope this helps,

Thanks Elisa,
But the issue is that we are trying to enable registration for an on going zoom meeting via update meeting api, we tried it with approval_type 0 and 1 but both time when we tried to add registrant using api it returns ‘Registration has not been enabled for this meeting:*****’ message

Thank you for calling attention to this, @zawar.ahmed! I am not seeing the behavior on my end – perhaps my meeting is not configured correctly. Can you share if you still seeing the behavior on your end? If so, I kindly ask for the exact meeting configuration and steps to reproduce.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.