Oauth app no longer working

Hello, I created a postman oauth app for the sake of testing some api end points for an integration i had to build. Everything was working fine until yesterday morning when all of a sudden upon requesting a new token (as it had expired) from postman, when clicking get access token, i got an error related to sub accounts.

this was very odd as it had been working up until then but now i was receiving that error. i tried the live chat and no one could really help me. I contact the owner of the account, my ceo to ask me if by any chance he had removed any permissions from my admin profile. he confirmed that all permissions were untouched. so again very odd that my oauth app (postman) that had been working all of a sudden was not authenticating throwing the sub account permission error.
This morning after speaking with someone else i was told to uncheck that from my app scope. i did and tried to get access token from postman again and lo and behold the sub account error that was thrown all day yesterday was gone yet another error popped up in the authentication screen
now not giving me any clue of what permission is needed. i do have them all. i also checked this url provided from the doc

in which you can pass you app id and tells you what permissions you are missing. and nothing there everything is fine. as last resort i recreated a new app and tried again and again same error you cannot authorize You cannot authorize app xyz. Honestly, no one is able to tell me what’s happening. support is not responsive meanwhile my system is crashing
I implore someone to give me some help

Hi @massimo.tarquini
Thanks for reaching out to the Zoom Developer Forum and welcome to our community!
I am sorry to hear that you are having issues getting an access token using your Oauth app.
I have a couple of questions about this issue, what kind of app are you working with?
An Oauth app or a Server to Server OAuth app?
If it is an OAuth app, is this an admin-level or a user-level app? and lastly if it’s an OAuth, do you intend to publish the app?

Also, feel free to reference this helpful guide on how to use the OAuth app type with Postman

I will also send you a private message to request more details about your issue, but in the meantime feel free to check that guide :slight_smile:

I was able to sort this out by removing all oauth app scopes i had and re-added the essential ones only. apparently by tinkering with the app scopes, i caused the addition of few app scopes that were conflicting with the existing ones

Happy to hear that worked @massimo.tarquini
Let us know if there is anything else we can do for you