Password change after the meeting is created

I change the links in the content because I can put only 2 links

I use JWT with the following endpoint: https://api.zoom.us/v2/

I have successfully created a meeting with the following json:

{“duration”:“30”,“password”:“Y623Hf”,“settings”:{“audio”:“both”,“host_video”:true,“join_before_host”:true,“mute_upon_entry”:false,“participant_video”:true},“start_time”:“2020-06-19T17:00:00”,“timezone”:“Europe/Rome”,“topic”:“Meeting topic”,“type”:“2”}

This is the response I received (note that the password is different from the one I wanted to set):

{“uuid”:“X1wTr2D+Rk2IXauaLesh0w==”,“id”:***********,“host_id”:“OJ-40mxATPmXHfVhxLrYFw”,“topic”:“Meeting topic”,“type”:2,“status”:“waiting”,“start_time”:“2020-06-19T15:00:00Z”,“duration”:30,“timezone”:“Europe/Rome”,“created_at”:“2020-06-17T09:31:28Z”,“start url”:“Link changed/s 7468313719?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJPSi00MG14QVRQbVhIZlZoeExyWUZ3IiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoidVp1Ym4zb3N3WlZ6cVZwTGRjZktuUmwxUjExdF9PaHJzRER4YUo4a3VWdy5CZ1VnU0M4dlFtdFVWbkJCTDAxeVZIYzFNaXRwWlRjemJrVkRVVEJJYW1WaFpIZEFOV0UzTVdZNU4ySmlOalk1WWprMFlqQmxNVFl5WkdRek0yUXdNakV4TUdNNVltUmpZVGMzWkdGbVpXUmlOV1ZrTkRVeVlqRm1PR0kwTkRRNU5ERmxPQUFNTTBOQ1FYVnZhVmxUTTNNOUFBTmhkekUiLCJleHAiOjE1OTIzOTM0OTAsImlhdCI6MTU5MjM4NjI5MCwiYWlkIjoiMXNuNVFXZFhUb2V6SkdEdE5YU2pOUSIsImNpZCI6IiJ9.ZwKwTV-hYH-mBB7WtEhfjXooctHBRX2FwxPXk4RNRhw”,“join_url”:“link changed /j/7468313719?pwd=dzA5RHVMaU04bFA1K3FidXJldDhNUT09”,“password”:“dnutHG”,“h323_password”:“579480”,“pstn_password”:“579480”,“encrypted_password”:“dzA5RHVMaU04bFA1K3FidXJldDhNUT09”,“pmi”:“7468313719”,“settings”:{“host_video”:true,“participant_video”:true,“cn_meeting”:false,“in_meeting”:false,“join_before_host”:true,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:true,“approval_type”:2,“audio”:“both”,“auto_recording”:“none”,“enforce_login”:false,“enforce_login_domains”:"",“alternative_hosts”:"",“close_registration”:false,“registrants_confirmation_email”:true,“waiting_room”:true,“registrants_email_notification”:true,“meeting_authentication”:false}}

But after some time (I have no idea how much) the password is no longer valid.

Using a GET this is the response:

{“uuid”:“Y+cmrFWWQVWZk4n1Y/WVyg==”,“id”:***********,“host_id”:“OJ-40mxATPmXHfVhxLrYFw”,“topic”:“Meeting topic”,“type”:2,“status”:“started”,“start_time”:“2020-06-19T15:00:00Z”,“duration”:30,“timezone”:“Europe/Rome”,“agenda”:"",“created_at”:“2020-06-17T09:31:28Z”,“start url”:“Link changed/s 7468313719?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJPSi00MG14QVRQbVhIZlZoeExyWUZ3IiwiaXNzIjoid2ViIiwic3R5IjoxMDAsIndjZCI6ImF3MSIsImNsdCI6MCwic3RrIjoidVp1Ym4zb3N3WlZ6cVZwTGRjZktuUmwxUjExdF9PaHJzRER4YUo4a3VWdy5CZ1VnU0M4dlFtdFVWbkJCTDAxeVZIYzFNaXRwWlRjemJrVkRVVEJJYW1WaFpIZEFOV0UzTVdZNU4ySmlOalk1WWprMFlqQmxNVFl5WkdRek0yUXdNakV4TUdNNVltUmpZVGMzWkdGbVpXUmlOV1ZrTkRVeVlqRm1PR0kwTkRRNU5ERmxPQUFNTTBOQ1FYVnZhVmxUTTNNOUFBTmhkekUiLCJleHAiOjE1OTI1ODUxNzAsImlhdCI6MTU5MjU3Nzk3MCwiYWlkIjoiMXNuNVFXZFhUb2V6SkdEdE5YU2pOUSIsImNpZCI6IiJ9.zjuy9NN7Rgu6dAGEHgTXX8kd-PCgSihKLizGTSE4h1s”,“join_url”:“link changed /j/7468313719?pwd=bWNGU2dHdWFMVDkwUy9jUjhFZlh6Zz09”,“password”:“SXH35s”,“h323_password”:“168012”,“pstn_password”:“168012”,“encrypted_password”:“bWNGU2dHdWFMVDkwUy9jUjhFZlh6Zz09”,“pmi”:“7468313719”,“settings”:{“host_video”:true,“participant_video”:true,“cn_meeting”:false,“in_meeting”:false,“join_before_host”:true,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:true,“approval_type”:2,“audio”:“both”,“auto_recording”:“none”,“enforce_login”:false,“enforce_login_domains”:"",“alternative_hosts”:"",“close_registration”:false,“registrants_confirmation_email”:true,“waiting_room”:true,“registrants_email_notification”:true,“meeting_authentication”:false}}

As you can see, the password is changed and obviously also join_url has changed

What am I doing wrong?

*This post has been edited to remove any meeting / webinar IDs

Hey @gcatnine,

I was unable to reproduce this issue.

Can you please try using the following request payload:

{
  "duration": 30,
  "password": "Y623Hf",
  "settings": {
    "audio": "both",
    "host_video": true,
    "join_before_host": true,
    "mute_upon_entry": false,
    "participant_video": true
  },
  "start_time": "2020-06-19T17:00:00",
  "timezone": "Europe/Rome",
  "topic": "Meeting topic",
  "type": 2
}

Thanks,
Tommy

Thank you very much.
After some tests, I understood what the problem is.
Using pmi and creating multiple meetings, even if each meeting has a different password, all meetings take the password of the last meeting created.
Using use_pmi = “false” passwords are kept, but the person invited appears to be entering without waiting for the host.

Any suggestions?

another question:
is it correct that the host have to use the start_url to start the meeting?
Thanks a lot for the help

Hey @gcatnine,

When using your personal meeting ID (PMI) to create a meeting (settings > use_pmi), it should use your PMI password you have set in your settings.

Make sure you are setting the respective join before host setting (settings > join_before_host)

Yes, the host should use the start_url to start the meeting.

Thanks,
Tommy