Possible Bug with Video Streaming version 1.7.8

I am having intermittent issues with the Video Stream Displaying for an attendee, and I can not determine the source of the issue. From what I am seeing this is a version 1.7.8 issue, I was unable to reproduce on 1.7.7. (I didn’t do extensive testing on 1.7.7), but the issue regularly occurs on 1.7.8

The Host is broadcasting and the Host is using the Native App
The Attendee is using FF 77.0.1 (64-bit), and also tried Chrome 83.0.4103.106 (Official Build) (64-bit).
Another Attendee is using IOS Mobile Safari (version not relevant).

Both the Host and the Attendee using FF / Chrome are on the same network i.e. have the same public IP Address. They have different Private IP Address, and are going out (to the internet) through the same Router.
The Mobile Safari user has a different public IP (I dont believe having different public IPs is relevant)

The Host broadcast is good.
The Attendee using FF / Chrome is not seeing the Video broadcast.
The Mobile Safari using is seeing the broadcast.

you can see the screen shots below, its blank for the FF user (and the same in Chrome).

you can see the output from Dev Console in FF.

Which version?
WebSDK version 1.7.8
The Host is broadcasting using the Native App, Mac OS Zoom version: 5.0.2.
One attendee is using FF 77.0.1 (64-bit), and also tried Chrome 83.0.4103.106 (Official Build) (64-bit).

Additional context
It seems intermittent, though most times not working, occasionally the stream will come through. If the host stops broadcasting. Both attendees see the “Shadow image” i.e., the image that displays when host is not broadcasting. When the Host starts broadcasting, the Attendee who is using FF. the “shadow image” disappears i.e., it recognises that Host is streaming, but the stream does not come through.

I regressed back to Version 1.7.7 - And I was unable to reproduce on the previous version


/* Set the Library dependency */

const meetConfig = {
    apiKey: window.wvZoom.apiKey,
    meetingNumber: window.wvZoom.meetingNumber,
    userName: window.wvZoom.userName,
    userEmail: window.wvZoom.userEmail, // must be the attendee email address
    signature: window.wvZoom.signature,
    passWord: window.wvZoom.password,
    error(res) {
        console.log("Joining meeting Error");
    success() {

    leaveUrl: window.wvZoom.leaveUrl,
    // isSupportAV: true,
    isSupportChat: false, //turn off chat option
    isSupportQA: false, // turn off QA
    isLockBottom: false, // allo the footer "control bar" to automatically hide
    success: function (success) {
        console.log("Init Success ", success);


here is the output from the Dev Console:

Here is the same Stream via IOS Mobile Safari

Hey @darragh.duffy,

We have a new version of the Web SDK coming out in a couple of days which should fix the black screen issue:

Please upgrade when it comes out, and let me know if that fixes the issue.


Hi @tommy I checked the new version (and ignoring the issues with captcha right now), I can see the new version 1.7.9 has not fixed the blank video see here:

As you can see, the Video is blank, I am in the webinar, and you can see that I am running 1.7.9, and everything looks good based on the console logs. I am say I have been doing a lot of testing over the previous 10 days, and its only version 1.7.7 that consistently works with the video, 1.7.8 very rarely works, and I only started looking at 1.7.9 today. I have yet to see the video stream coming through. The audio is fine both in 1.7.8 and 1.7.9 - I have never had an issue with audio.

Hey @darragh.duffy,

Thanks for these additional details, our engineering team is looking into this and I will get back to you asap. (CS-1906)

Apologies for the inconveince.


Thanks @tommy for the update. One of your engineers did reach out to me to do a live Troubleshooting. I responded, and can do a live troubleshoot at any time.

1 Like

Thanks for letting me know @darragh.duffy! :slight_smile: