Problem starting the SDK Demo BOT for zoom in LINUX

I am currently Using the latest version of sdk v6.1.0.22534
I am trying the provided ZOOM SDK BOT demo to work on linux to fetch participants id and recording automatically from zoom it should also automatically join and leave meeings

My problem is whenever i run the demo i am only getting this results

redz@redz:~$ /home/redz/Desktop/zoom/meetingSDKDemo/bin/meetingSDKDemo
self path: /home/redz/Desktop/zoom/meetingSDKDemo/bin
Readfile success.
Reading…meeting_number: “89278569640”
Reading…token: “eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpc3MiOiI3VzJsWFJFbVFJdTA0SXV1aHRRM2dRIiwiZXhwIjoxNzE5NTM3NTQzfQ.hOy-lXNEVTLUow0V1TNhmqLd1T_E7W-WYBIki1Hm8Vo”
Reading…meeting_password: “356333”
Reading…recording_token: “”
Reading…GetVideoRawData: “true”
Reading…GetAudioRawData: “true”
Reading…SendVideoRawData: “false”
Reading…SendAudioRawData: “false”
Meeting Number: 89278569640
Token: eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpc3MiOiI3VzJsWFJFbVFJdTA0SXV1aHRRM2dRIiwiZXhwIjoxNzE5NTM3NTQzfQ.hOy-lXNEVTLUow0V1TNhmqLd1T_E7W-WYBIki1Hm8Vo
meeting_password: 356333
GetVideoRawData before parsing is : true
GetVideoRawData: 1
GetAudioRawData before parsing is : true
GetAudioRawData: 1
SendVideoRawData before parsing is : false
SendVideoRawData: 0
SendAudioRawData before parsing is : false
SendAudioRawData: 0
directory of config file: /home/redz/Desktop/zoom/meetingSDKDemo/bin/config.txt
Init meetingSdk:success
AuthService created.
AuthServiceEventListener added.
AuthSDK:token extracted from config file eyJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJpc3MiOiI3VzJsWFJFbVFJdTA0SXV1aHRRM2dRIiwiZXhwIjoxNzE5NTM3NTQzfQ.hOy-lXNEVTLUow0V1TNhmqLd1T_E7W-WYBIki1Hm8Vo

i tried manually joining meetings creating recordings and leaving a meeting but nothing happens to the demo what should i do? can anyone help me?


@redz.alegato.ra for a start, this is not a valid meeting sdk auth token

Here’s a guide on how to generate it

Just to set expectations, after reading your requirements, this sample code generates primarily 2 seperate files. 1 YUV420 video file. 1 PCM audio file. The video file is in raw format, and it does not have audio.

If you are trying to join meeting which are external to your tenant, you will need to publish your General App / Meeting SDK. If you are just joining internal meetings, you do not need to publish your application.

You will need to mux the audio and video yourself.

I used the meeting token fetcher you provided in the repo

and i already created an app and added theapp for local testing

@redz.alegato.ra you could also take a look at this Meeting Bot Starter Kit from Zoom:

@redz.alegato.ra the token looks very different from what the python code would generate.

This is what you are using

This is what is expected

OKAY I’ll try the suggestions thanks

I used this guide to create a jwt fetcher using node js

this is the result token

is this token wrong?

tried it and started the bot again

and this is the result

may i know what i did wrong? the bot is still not joining


@redz.alegato.ra can you paste the signature here?

Generated JWT token:



tokenExp is missing
meetingNumber should be mn, and it should be in integer and not string format
role should be integer format

Anyway for linux SDK, i suggest removing mn and role totally as they are not used.

OK, thanks. I’ll try your suggestions.