Q&A Report API - empty result issue

Description
I reported a issue in Oct 2020: Q&A Report API - empty questions issue
It resulted in an bug ticket: ZOOM-203275
It seemed to be solved, but now something similar happens again at Zoom Webinar ID: 96210850597

When running a GET Request on the Report Q&A API, I sometimes get an empty result on the question details, while the CSV Export file on the GUI shows the questions.
We have many Webinars where it works fine (CSV & API have the same result), but also some where it have a different result.

Error
There is no error message - Return HTTP 200 OK. But the data array “question" is empty - but the CSV File Export shows data.
{
“id”: 96210850597,
“uuid”: “TLNe+YkiRwm4uwsIsUq+wQ==”,
“start_time”: “2021-02-24T09:15:49Z”,
“questions”:
}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Knowing the endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

Which Endpoint/s?
v2/report/webinars/:webinarId/qa

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. GET https://api.zoom.us/v2/report/webinars/99412543851/qa
    webinarId: e.g. 96210850597
  2. See error

Screenshots (If applicable)

Additional context
Add any other context about the problem here.

Hey @sven,

Thanks for reaching back out about this, and apologies this issue has cropped up again.

I believe this is a bug, and we’re looking into this once more (ZOOM-203275).

Thank you,
Will

We have identified more Webinars with this issue in the last days:
Webinar Id: 96381760957, 96933422826

This Webinar form 26 Jan 2021 works fine: 92518870851

Maybe this info does help to identify the issue :slight_smile:

Hi @sven,

Thanks for sharing these additional examples. Our team has identified the bug causing this issue, and we are working on addressing this in our next release. (ZOOM-203275).

Thanks,
Will

Hi,

Just to confirm that we are also experiencing the same issue.
Looking forward to having it fixed soon.

Hi @v.hristov,

This will be addressed in an upcoming release and is on our radar. Thanks for letting us know.

Best,
Will

Hi @will.zoom,

Any updates on this bug (ZOOM-203275)? Essentially, at the moment the Zoom API in its part for reporting on the webinar Q&A is completely broken for almost a month now. I think this should have been treated as an urgent issue, rather than taking this amount of time to bring a broken service up…

Hi @v.hristov,

Thanks for following up on this. Our team has been working on a solution, and this issue should be addressed in our next release. This will likely be in a matter of weeks.

Thanks,
Will