Rich LTI stopped functioning with D2L Error 2207

We have lost all use of Rich LTI zoom App. We use this from a d2l LMS.

Has anyone gotten this Error Code 2207 before? Is there a known fix?


Something wrong happened, please try again later(2207).

Error Code 2207 - v=2.0;clid=aw1;rid=INT_2292c6c36d5f341f

How To Reproduce
Steps to reproduce the behavior:

  1. from d2l LMS - click Zoom LTI link “
  2. This brings us to the error page.
1 Like

I wish I was commenting with a solution, but unfortunately I’m just here to say I’ve got the same issue. Also using D2L and now our instructors can no longer use Zoom class easily.

We reset the secret and that solved it!

1 Like

Awesome, I did the same and also fixed it, thanks for the heads up :smiley: !

Thanks for sharing your solutions @bterry2 & @zdokuchic!

How do you reset the secret?
We are seeing the same error across the platform.

We are also getting the error @conrad - did something change?

how do you reset the secret? By re-entering? or remaking the App link?

We’ve tried resetting the secret via the marketplace app - but this didn’t seem to work for us.

I followed the instructions here but clicked on “Added apps” instead of “Create apps”

Any idea how to fix this issue with Canvas? Or will it eventually be resolved I don’t have access to the API Key/Secret Credentials because its via my schools integration of zoom on canvas.

1 Like

from the recent comments, I believe that this issue only occurred today for some customers who use LMSs such as Canva and Moodle, so I think it is a global issue and not a user-specific problem.
I have contacted Zoom and they confirmed the issue (it is regarding Zoom API) and they are trying to resolve the problem ASAP

seems to be connected to the following topic:

Hi guys,
We have the same issue. Any idea how we can fix it?

Thanks so much!

On Monday, January 23, 2023, be cafeful about making any changes. There appears to be a problem with the REST API, which may affect the ability of an LMS to work with Zoom.

1 Like

Thank you all for the solution here. We were also affected by this problem this morning.

Hello All - We had to reset our secret again as well. Once that updated secret is uploaded to our LMS we are back up.

Hi , @sharon.kitching , @conrad , @gigis21, @ricoe, @babbage , @dbracelccc , @kmagpoc , @bterry2, as Rico identifies, this error you were seeing today (Jan 23, 2023) was most likely connected to an OAuth authentication issue reported we posted to our status page here -

The system issue was identified and should now be resolved. Our apologies for any disruption, please do let us know if you continue to see the issue.


LTI integration with Canvas is now working


1 Like