runRenderingContext stopped working today?

Zoom Apps Configuration
Zoom App with runRenderingContext enabled, both in Zoom App SDK Config (web interface), an in JS config capabilities . Latest Mac Zoom client 5.11.3 (9065).

Up until today runRenderingContext was working fine, now it suddenly seems to do nothing, except perhaps a brief flicker in the video. Am specifically calling it with options view: 'camera'

runRenderingContext returns {message: 'success'}, but nothing happens. Expected behavior: the video canvas should be redrawn (what was happening until today).

Troubleshooting Routes
Tried uninstalling and reinstalling app. Tried creating a new app from scratch. Tried updating Zoom client. Tried restarting computer.

How To Reproduce
Call runRenderingContext in any app.

A bug was fixed in 5.11.3 to help prevent a white flash when turning on camera mode.

Maybe the code needs to be updated to also call drawWebView, but in 5.11.0 this was called automatically. So my guess is the client was updated to the newer version.

Thanks @Robert.Wallis , this pointed in the right direction. Solved it by explicitly setting the version in zoomSdk.config and calling drawWebView after runRenderingContext.

1 Like