Server to Server OAuth pending activation for a week now

Hello guys

I have tried to create a S2S Oauth app in order to retrieve the user information (department, location, license type) on a monthly basis, as our finance department is asking for the details (regional organization and billing coming from HQ) in order to get the right split.

I followed the doc:

  • filled all necessary fields in my app in zoom
  • in the admin role (my account), in advanced features, I allowed S2S Oath to View and Edit.
  • in the admin role (my account), in users permission, I allowed Users to View and Edit.

Yet, the activation button of my app stays greyed out (since monday)

I tried to open a ticket, but it redirected me to this forum.

Hi @bwayan75
Thanks for reaching out to the Zoom Developer Forum, I am happy to help here!
Have you been able to troubleshoot this issue?
Can you make sure to fill up all the basic information such as Developer name and email before activating your app?


I filled everything (it would be mentioned if any field was missing for activation).
Anyway, I modified my code to make it with users OAuth instead

Interesting, I will send you a Direct Message to follow up on this

Sharing the solution for visibility.

When having issues with Server-to-Server Oauth app activation, make sure to enable Zoom for Developers in Advanced Features

Please have the account owner or Admin enable Edit permissions for this feature under User Management->Roles->Admin->Advanced Features and the user should be able to Activate the app.


Hi Bwayan,
Hope so you’re doing well, to create a S2S OAuth app on Zoom. However, if the activation button of your app remains greyed out, it may be because there is an issue with the configuration of your app.

To resolve this issue, you can try the following steps:

  1. Ensure that all the fields in your app are filled out correctly, especially the required fields.
  2. Check that you have enabled the correct permissions in the admin role and user permission settings.
  3. Double-check that you have completed all necessary steps in the documentation.
  4. Try creating a new app and repeating the process.

If these steps do not resolve your issue, you can try reaching out to Zoom support for further assistance.

Hope so this will help you!

Bryce June

I solved the issue thanks to Elisa via PM

Case can be closed

1 Like