Unable to activate server-to-server oauth app

API Endpoint(s) and/or Zoom API Event(s)


I’ve prepared a server-to-server oauth app, filled out all the fields, and now I’m hoping to activate it. The activation page says “your app is ready for activation”, and I’ve checked that I’ve filled out all the fields. However, I’m unable to activate the app. I’d be grateful for any insights or advice!


The activation button itself is disabled, and I’m not sure why.

I note that only the App Credentials and Scopes tabs have checkmarks, but I can’t see any missing fields.

Does your user have a role that has permission to edit server-to-server OAuth apps and permission to do the same things that match your app’s scopes? You can audit your scope and role permissions by visiting https://marketplace.zoom.us/apphelp/<appID> where <appID> can be retrieved from the links on the Created Apps page.

Your role might also need “Advanced Features”; “Marketplace (Manage and install Marketplace apps for the Zoom account)”.

Hi @MultiplayerSession thanks so much for coming back to me.

I can’t attach the screenshot, but I’ve got listed:

  • View all user meetings (privilege satisfied)
  • View and manage all user meetings (privilege satisfied)

I’ll check in with our administrator about being granted “Advanced Features ”; “Marketplace (Manage and install Marketplace apps for the Zoom account)”. It’s a bit of a round trip for each request but hopefully I can check again tomorrow.

Really grateful for your answer.

Thanks for the well-written question. My understanding is that activating the application is equivalent to installing it on the Zoom account, and that is a permission we granted to the limited-privilege “developer” role we’re using in our setup.

Note that the user that owns the application will need to maintain the same role permissions that the app’s scopes need on an ongoing basis (in other words, anything the app can do, the owning user also needs to be able to do), so you might want to plan that out with your administrator while you’re having this conversation.

Thanks again. Our IT folks are being (understandably) cautious about rolling out permissions. They tried “view market place apps” - but that didn’t have the desired effect, so I’ve asked again if they’d grant “make and manage” :crossed_fingers: I’ll report back. Really appreciate you sharing your experience.

I’m afraid that wasn’t it! I did solve the puzzle of the Information checkbox - you can complete that level by setting an icon for the application.

I wonder if the issue is that I just haven’t completed the Feature tab. But I can’t see what else I’d need to do there… It shows:

  • Add feature (heading)
    • It kind of looks like there ought to be something between this and the next heading, but there’s not.
  • Token (heading)
    • Secret token
    • Verification token
  • General features (heading)

I’ve got Event Subscriptions disabled there, because I don’t think I need it - and that’s all I can see on that page…

Ok - I’ve now successfully got my checkbox in Features - which I did by adding an event subscription. Now all tabs have a check except for activation.

  • :white_check_mark: App Credentials
  • :white_check_mark: Information
  • :white_check_mark: Feature
  • :white_check_mark: Scopes
  • :green_square: Activation

I was able to grant the following scopes:

Scope Privilege satisfied
View all user meetings :heavy_check_mark:
View and manage all user meetings :heavy_check_mark:
View and Manage marketplace app information for the account :heavy_check_mark:

I can’t think what else could be missing :person_shrugging:

Oh, and just to be sure, I’ve attempted to obtain an access token using the app credentials, and I see this:

{"reason":"The application is disabled","error":"invalid_client"}

I have to assume it’s because I’ve not been able to press that button. It’s frustrating that the activation page still says:

Your app is ready for activation