Activating 'Server-to-Server OAuth' App


I have created a Server-to-Server OAuth apps however, in the last Activation page I get the statement Your app is ready for activation but I am unable to click the Activate your app button.

I cannot find any documentation to help me establish what I have done wrong. I’m hoping somebody can point out my oversight.

Hi @technical.integratio ,

Have you filled out all the info under Basic Information and Developer Contact Information? And you see the “Activate your App” button but you are unable to click it? It appears like this:

Screen Shot 2022-07-06 at 11.29.35 AM

Is the button greyed out?

Let us know!

Welcome to the Developer Forum, @technical.integratio! As a sanity check, did you complete all the required fields? You have to select at least one scope in order to activate the ‘Server-to-Server OAuth’ App . Down below is documentation on the process of subscribing to OAuth Scopes:


Thank you for replying. Yes, fields filled out and all boxes (circles) have a tick in them apart from the last Activation section. And yes, I see the same as your image but the button is pale ‘greyed out’.

That’s strange! If you have all fields filled out, and boxes checked then you should be able to activate it. Please verify that the administrator for your Zoom account enabled the view and edit permissions for the Server-to-Server OAuth app.

If all of the above is verified, then I’d suggest submitting a support ticket here, our support team will be able to take a closer look at what may be happening.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.