Settings fields are ignored in create meeting endpoint

When creating a meeting with “auto_recording” set to “cloud”, no recording is generated.

{“code”:3301,“message”:“There is no recording for this meeting”}

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create a meeting with body:
    {“topic”:“some topic”,“duration”:60,“start_time”:“2020-05-18T15:42:53Z”,“type”:2,“settings”:{“auto_recording”:“cloud”,“join_before_host”:true,“participant_video”:true}}
  2. Participants join
  3. End meeting
  4. Call /meetings/{uuid}/recordings, with the uuid returned from api.
    {“code”:3301,“message”:“There is no recording for this meeting”}


Hey @Tal,

Can you share the JSON response returned from the create meeting endpoint so I can debug?

Make sure you are passing in the updated meeting UUID, and waiting until the Cloud Recording has completed.

You can use the Cloud Recording Completed endpoint to get the updated meeting UUID and be notified when the recording is accessible.