Sharing dispState value incorrect


#1

I am trying to use the result of “zStatus Sharing” to determine the instructions the ZR is showing on the screen so my controller app can display the same instructions. However, the “dispState” value seems to be incorrect sometimes.

One example:

  1. Start a presentation-only meeting and display laptop sharing instructions via: "zCommand Dial Sharing Duration: 30 Displaystate: Laptop Password: ".
  2. Send “zStatus Sharing”.
  3. Observe in the response that “dispState” is “None” even though instructions are being shown on the Zoom Room display.

This seems like a bug to me. Does anyone have any thoughts, workarounds, or timeline for a fix?

I am running Beta 15 on a Mac Mini.

Thanks,
Steve


#2

We do in fact have a bug. Actually, it’s a pair of bugs; one of the sharing notifications is missing on the mac, and the other sharing notification is missing on Windows: We’re working on these:

ZOOM-68586: WinZR: Sharing message missing

For the ZAAPI CLI, you get:

*e SharingState state: Receiving

But you don’t get:

*s Sharing isDirectPresentationConnected: on

ZOOM-68587: MacZR: Sharing message missing

For the ZAAPI CLI, you get:

*s Sharing isDirectPresentationConnected: on

But you don’t get:

*e SharingState state: Receiving


#3

It looks like there has been an update. In our latest code base, the situation for Mac and Windows is:

For the ZAAPI CLI, you get:

*s Sharing isDirectPresentationConnected: on

But you don’t get:

*e SharingState state: Receiving

Our ship date slipped to January 27th, so we’ll consider pushing out a beta 16 with this update.


#4

Thanks!

You’re mentioning '*s Sharing IsDirectPresentationConnected" and “*e SharingState state”, although the problem I’m seeing is with “*s Sharing dispState”. Are the issues related?


#5

@Aveo_Systems

Hello, we are currently investigating this issue.


#6

Any info on if you were able to reproduce this issue and if there will be a fix in the next beta release?

Thanks,
Steve (from Aveo Systems)


#7

We fixed this item. There is one other item we are trying to fix, and we may have a beta 16.

Also: Yesterday we pushed out a new version of the desktop clients for Mac/Windows/Linux; the look and feel is quite different.

-Scott


#8

The dispState bug was fixed for beta 16:

https://ota.zoom.us/ZoomRooms/ZRCSAPI/

-scott


#9

I tested this with Beta 16, and that case works now. Thank you.

However, there is at least one other case where dispState is out of sync.

  1. Start a sharing-only meeting with HDMI content (via BlackMagic) using: "zCommand Dial Sharing Duration: 30 Displaystate: None Password: "
  2. Disconnect or stop the HDMI content source so that it is no longer sending an HDMI signal to the Zoom Room computer.
  3. Observe that the Zoom Room now shows laptop sharing instructions, but a zStatus Sharing message gets sent that has dispState “None”.

Not sure if you prefer to see this issue on this thread or if I should start a new one.

Thanks,
Steve


#10

Hello Steve,

Yes, I have reproduced the issue. If you use “zCommand Dial Sharing Duration: 30 Displaystate: None Password:” and then starting sharing anyways, once the sharing ends it will automatically display the instructions for the source of what you shared on the screen without updating dispState. I don’t think a displayState input of “none” is ever suppose to be used in that function though since the point of that function is to display instructions on the screen and displayState input of “none” displays nothing. I would simply avoid using that command with displayState input “none”.


#11

Hi Zach,
For me, I use displayState for sync instructions showing between my controller App and ZRoom.
When the dial sharing ends, displayState: none, I can simulate show instructions again, but if someone exit my controller App, then start it again, it can’t synchronize with instructions show. Because I have no information from ZAAPI what is showing in screen. And that is bad.
Actually In API there is no short way to get actual system state from ZAAPI: I need to get call info, sharing status, inforesult and analyze all of it with incorrect value of displayState at final.


#12

Hi @Raz1988 ,

I don’t really understand your last post. Can you explain again? I have tried disconnecting ZAAPI from the ZR after starting a share meeting using “zCommand Dial Sharing Duration: 30 Displaystate: Laptop Password:” and then reconnecting. the dispState is still correct.

The only time I can reproduce that it is out of sync is when I do “zCommand Dial Sharing Duration: 30 Displaystate: None Password:” then start sharing, then disconnect my sharing, then the laptop instruction displays on screen but dispState is still none. Are you saying that you must use “zCommand Dial Sharing Duration: 30 Displaystate: None Password:”?


#13

Zach,

Thanks for your response. I think what you’re saying is “don’t use Displaystate: None”. My questions to you then are:

  1. What command should I use to start a sharing-only meeting with HDMI?
  2. If instructions are being displayed (HDMI, Air Play, etc.), then how do we make them disappear? (Maybe the user doesn’t want to see them anymore.)

Thanks,
Steve


#14
  1. I think there are not instructions for sharing only meeting with HDMI? I have never seen them before. But the user can start sharing with HDMI without any instructions displayed.
  2. If you take a look at our own ZRC controller, there is actually no feature for hiding the instructions during a sharing only meeting.