Stuck on 'Waiting...' for Joining meeting, but create meeting is OK

Description
When I create a meeting, everything is perfect.
When I join an exsiting meeting, it got stuck on ‘Waiting…’ then nothing happens.

Which version?
v5.0.24433.0616

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Go to ‘…’
  2. Click on ‘…’
  3. Scroll down to ‘…’
  4. See error

Screenshots
If applicable, add screenshots to help explain your problem.
(Function)

0 if SUCCESS: MobileRTCAuthError(rawValue: 0)

Zoom (SDK): Authentication task completed.

error was 0

2020-07-15 20:57:08.526576-0700 WeZoom[3942:1186689] Can’t find keyplane that supports type 4 for keyboard iPhone-PortraitChoco-NumberPad; using 25686_PortraitChoco_iPhone-Simple-Pad_Default

2020-07-15 20:57:08.552125-0700 WeZoom[3942:1186689] Can’t find keyplane that supports type 4 for keyboard iPhone-PortraitChoco-NumberPad; using 25686_PortraitChoco_iPhone-Simple-Pad_Default

Getting started on Joining a Meeting …

onJoinMeeting, response: MobileRTCMeetError(rawValue: 0)

Meeting State: MobileRTCMeetingState(rawValue: 1)

2020-07-15 20:57:11.698831-0700 WeZoom[3942:1186689] Metal API Validation Enabled
Smartphone (please complete the following information):

  • Device: [e.g. iPhone6]
  • OS: [e.g. iOS8.1]
  • Version [e.g. 22]

Additional context
Add any other context about the problem here.

Hi @aabudureheman,

Thanks for the post. Thanks for the reply. We are able to identify an issue for the situation you are mentioning. When the setMobileRTCRootController is not configured and the video preview feature has enabled(It is enabled by default), the join meeting process will struggle at presenting the video preview view. We will fix this in the next release.

As an alternative solution, please try to configure the setMobileRTCRootController (https://zoom.github.io/zoom-sdk-ios/interface_mobile_r_t_c.html#a74d0a3110932a0f9506b05d6e235b3ba) or call disableShowVideoPreviewWhenJoinMeeting(https://zoom.github.io/zoom-sdk-ios/interface_mobile_r_t_c_meeting_settings.html#a85841243faa0e974b243ab093d53be88) to disable the video preview, this will work as expected.

Thanks!

Hi everyone,

Any Update on the above issue.

Hi @raju.gupta,

Please see my reply above. Hope this helps. Thanks!