Template_id not taken into account when creating a webinar using api

Hello,

I am using the Zoom API to create a webinar - this is all working as expected! … Except for one thing.

I am including a template_id but this does not have any effect.
I know the template exists.
I know I am passing the correct template_id as I pulled it from the Zoom API.

I am able to list webinar templates and retreive their ids using the List webinar templates. When I try to create a webinar using these ids, into the template_id field, the post response does not include the template_id field. I tried putting the template_id in my json data. As it didn’t work, I tried putting the template_id in the url : https://api.zoom.us/v2/users/reE8HRyKToKTLRnU_8Co7w/webinars?template_id=YNFfLONkSMubpMXvVA1Sog

https://api.zoom.us/v2/users/me/webinars?template_id=YNFfLONkSMubpMXvVA1Sog

In each case a webinar is created but the post response doesn’t contain a template_id and when I look at the created webinar it is as if it was created without any template.

Are you using the same User ID to list the templates and create the meeting? I’m wondering if the template ID is owned by another user and that’s causing the conflict here.

If you continue to run into issues using this API I recommend reaching out to our Customer Support Team to see if they can assist further.

Hello Max,

Thank you for your answer.

Yes I am using the same user id.

And I come from the customer support.

Benoit

Hello,
You need to enable the admin template feature. You can see this here:https://marketplace.zoom.us/docs/api-reference/zoom-api/methods/#operation/meetingCreate

Thanks!
Chris