The android SDK "sample" demo app stuck in "preparing meeting" black screen


When I run the android SDK sample demo app, I try to join a meeting with the correct meeting ID, it worked good several days ago. However, today when I try to do the same thing, with a updated meeting ID of course, it stuck in the preparing meeting black screen, the enter password dialog hasn’t showed up at this point. The meeting ID is valid because I can access the meeting via the Zoom Android App. How can I resolve this issue?

My device is:
Android 10 (Q), Pixel 2 XL

Thank you in advance!

Hi Guangda,

Thanks for the post. I might need more information in order to help you, could you provide the following info:

  1. What is the SDK version you are using?
  2. Is this issue reproducible? Does it happen for all meetings using the demo app or for some meetings?
  3. Could you provide the SDK log for us to further investigate? You may find the instruction of how to enable and to retrieve the log here:

Hope this helps. Thanks!

Hi Carson,

Thanks for your reply! I was using the latest SDK, the issue is reproducible every time I run the SDK. It only happens in my app, the demo app works good.

The issue happened because I didn’t pass the meeting password when joining the meeting and the built-in password dialog doesn’t show up either, so it just stays in the “prepare meeting” black screen.

After I pass the meeting password with joinMeetingWithParams(this, params), it won’t start the meeting screen automatically, I have to click the android zoom notification to open the video meeting view. It can now join the meeting successfully though.
Is there a way to launch the video meeting view MeetingActivity automatically without clicking on the zoom notification?

Hi Guangda,

Thanks for the reply. I tried to reproduce this with our demo app but no luck. Did you override the following callback onMeetingNeedPasswordOrDisplayName (, if you override it, SDK will not show the password pop-up(some people do not like the pop-up), and will use the password passes in this callback to try to join the meeting.

However, if you override this callback, you won’t be able to join the meeting by clicking the notification. So something else might be not working. Could you provide the SDK log for us to further investigate? It will be hard for us to troubleshoot this if we could not reproduce it or do not know the log.


Hi Carson,

I didn’t override the call back onMeetingNeedPasswordOrDisplayName. Seems the issue might be device specific, it only happened on my Pixel 2 XL (android 10), other devices work good, including those running on android 10. Also, the issue was gone after I un-install the Zoom SDK demo app. When I install the demo app back to try to reproduce the issue, the issue doesn’t happen again, so I’m unable to get the logs. Not sure if the Zoom demo app conflicted with my own app.

Hi Guangda,

Thanks for the reply. I am having the same device + same system (handshake here :slight_smile:) and everything is working well. Sometime when you previously had a built with errors on the phone, the new build might not override the old one so the error persists. It usually happens when you are switching demos from different versions of SDK(The app id is the same). But this is just a guess, might not be the root cause of the issue you are facing.

Please let me know if you are able to reproduce this issue or get the SDK log for further investigation. Happy Zooming!