Trouble with Webhook to ASP.NET Web API

I’m having trouble all of a sudden getting the payload from a Zoom webhook. This code was working previously and now it’s not.

I have an ASP.NET application hosted on Azure, using a Web API. I have a very simple POST handler that takes a .NET object, which I derived from the JSON request body. The code as is has two issues:

  • If I don’t decorate the function with Accept-Verb(“GET”), it throws a 405 error saying that the method doesn’t support a GET, but previously it worked when just set up to accept a POST.

  • Once I do accept GETS, the function fails because the payload is null, even though if I look in the Zoom call logs there is valid JSON data in there.

I’ve tried declaring the function both synchronously and asynchonously, with no difference. I get the same results sending a dummy call from Postman.

It seems like the way in which the request is being received is causing the request body to be missed.

Any help is appreciated!

Hey @rich1 thanks for reaching out and welcome to our forum.

That is strange behavior. It is correct that our webhooks are post requests to your webhook endpoint.

Can you send me the errors as they appear in your logs, and steps to reproduce or code I can try on my end?


This only happens in V1 of the Webhooks. I’ve moved to the newer version since V1 is going to be deprecated. It receives the webhook when the controller is set up to receive only POST as a verb. Note that I used to have my V1-based controller declared to accept only POST, and it worked, so this is a recent breaking change to the V1 webhooks.

Hey @rich1,

The V1 webhooks will stop working soon.

I would suggest moving to V2 if you have not already.

Here is our updated docs for webhooks,

Let me know if this helps!