Turning off chime when entering meeting


#1

I am currently having trouble turning off the chime when you join a meeting. The solutions I’ve done so far is:

Preface - I’ve created a MyMeetingActivity that extends MeetingActivity. I’ve confirmed that code that runs here is code that is running during meeting process. I can even try to get InMeetingService instance in here, without null.

  • I’ve tried to create InMeetingService and call setPlayChimeOnOff(false) in the onCreate method, but I can still chime when I enter the meeting room. I have not tested multiple devices yet.
  • I’ve tried to call onMute(true) in onCreate, then immediately call onMute(false), but I can still hear chime.
  • I’ve tried to do the above bullet points, but in the onMeetingConnected method. Still same results.
  • I made MyMeetingActivity implement InMeetingServiceListener, and tried to do the first two bullet points in onMeetingUserJoin method, but same issue.

So currently, I am not sure how to go from here to try to solve turning off chimes when joining a meeting.


#2

Hi,

setPlayChimeOnOff(false) only works for meeting with more than 2 people.

When host start the meeting, only he can call this API to set Chime off. After he set chime off, when third participants join meeting, there will be no Chime played.

Best

Wei

 


#3

Wei, 
*How* does host of meeting- i’ve looked through al settings & options and cannot locate.
(2+ people) set chime to OFF when participants join?

Thank you


#4

When you start a meeting in Android device, you can click “More” button, “Play Enter/Exit Chime” will be located in the popup window