"User does not exist: me." Error Code : 1001

Description
I am having a strange issue at zoom API to create meetings, It clearly says to use “me” here


, I can fetch the meetings fine at/v2/users/me/meetings with get request, But if I try to post there to create a meeting , It gives me 404 not found with 1001 as error code.

Error
{
“code”: 1001,
“message”: “User does not exist: me.”
}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth V2

Which Endpoint/s?
Type: POST
Endpoint : /v2/users/me/meetings
As said above, GET works and lists all meetings from my account, But POST doesn’t.

How To Reproduce (If applicable)
Steps to reproduce the behavior:
I followed your documentation, Here are steps,

  1. Create an app with user privilege (level),

  2. Use URL to get the code

  3. Get tokens by using the code you got from step 2

  4. Use GET request at /v2/users/me/meetings, That should fetch meetings fine

  5. Add below as request payload

    {
    “topic”: “Test topic here”,
    “type”: 2,
    “start_time”: “2020-05-20T12:02:00Z”,
    “duration”: 20,
    “schedule_for”: “Test purpose”,
    “timezone”: “Asia/Kolkata”,
    “password”: “abctest”,
    “agenda”: “To test zoom api”,
    “recurrence”: {
    “type”: 2,
    “repeat_interval”: 2,
    “weekly_days”: “1,2,3,4,5,6,7”,
    “end_times”: 5
    },
    “settings”: {
    “host_video”: true,
    “participant_video”: true,
    “cn_meeting”: false,
    “in_meeting”: true,
    “join_before_host”: true,
    “mute_upon_entry”: true,
    “watermark”: false,
    “use_pmi”: false,
    “approval_type”: 0,
    “registration_type”: 1,
    “audio”: “voip”,
    “auto_recording”: “local”,
    “enforce_login”: false,
    “registrants_email_notification”: false
    }
    }
    Use POST Request at /v2/users/me/meetings

Screenshots (If applicable)
https://prnt.sc/saursc & https://prnt.sc/saur61

Hope this helps, I searched in forum to see if I could find solution but I didn’t, Google didn’t help either.

Let me know, (and yes restricting users to put 2 links and only one image is idiotic)

Thanks.

I think this is because you are providing a “schedule_for” property. That is if you want to schedule on behalf of another user, then you would provide that user’s Zoom ID or Email address. Try removing that property from your payload.

Thanks a million, Yes that solved it.
The response should have showed that to me about it instead of saying user “me” not found.

Thanks for your help @samly!!!

I just ran into this exact same problem, and this forum post was the only thing that helped.

The error message is really confusing and does not make sense to show it that way. It should instead say the username being used in the ‘schedule_for’ property like so:

{
“code”: 1001,
“message”: “User does not exist: Test Purpose.”
}

Hey @christo1,

Thanks for the feedback, we will work on fixing this error message.

-Tommy