User Does Not Exist ( Error Code 1001 )

Using this template helps us debug your issues more effectively :slight_smile:

Description
I want to create meeting using JWT credentials and the web SDK.
It works for one account (free account - [REDACTED] )
but it doesn’t work for a pro account i’m testing out ([REDACTED])
i’m getting above error
Meeting could not be created. User does not exist: [REDACTED]

That account has another 7 users defined - I get the same errors for them as well.

Error
The full error message or issue you are running into.

Which App Type (OAuth / Chatbot / JWT / Webhook)?
Knowing the endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.
JWT

Which Endpoint/s?
Knowing the API endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

/users/{id}/meetings

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)
If applicable, add screenshots to help explain your problem.

Additional context
Add any other context about the problem here.

Here is the JWT I generated with the account that doesn’t work

[REDACTED]

Hi @simkin

Thank your for reaching out to the Zoom Developer Forum, I am happy to help here!
Can you please share the entire request body that you are passing when you are attempting to create the meeting so we can debug further?

When you make the call have you tried passing the user ID in place of the email address and see if that makes a difference?

Additionally, can you try regenerating the JWT key and ensure it belongs to the same account as the user.

Thanks
Elisa

First off, here is the request and payload:

/users/{zoom_user_id}/meetings

this is the payload (php)
$starttime is $dt->format(‘Y-m-d’).‘T’.$dt->format(‘H:i:s’); // current time

        $payload = [
            "topic" => "Class",
            "type" => 2,
            "start_time" => $starttime,
            "duration" => 90,
            "schedule_for" => 'smkn@esdikay.com',
            "timezone" => 'Asia/Seoul',
            "password" => 'myclass',
            "agenda" => 'class',
            "settings" => [
                "host_video" => false,
                "participant_video" => false,
                "cn_meeting" => false, // china
                "in_meeting" => false, // india
                "join_before_host" => true,
                "jbh_time" => 5,
                "mute_upon_entry" => true,
                "use_pmi" => false,
                "approval_type" => 2,
                "audio" => "both",
                "auto_recording" => "none",
            ]
        ];

here are the 3 attempts with different IDs

all using the exact same code for generating the request. the only thing different
is the ID, the API key and secret (since they’re tied to the ID) and the resulting JWT.

JWT #1
[REDACTED]

  1. code: 1001
  2. message: “User does not exist: hlW8hlimQoKuvTuvF8b1IQ.”

JWT #2
[REDACTED]

  1. code: 1001
  2. message: “User does not exist: reverazoom01@gmail.com.”

JWT #3
[RECACTED]

Hey @simkin,

First, please make sure to redact any information that may pose a security risk - such as emails and JWT tokens - from your forum posts

If you would like to share information with our team privately, please submit a ticket and include a link to this thread. You can submit a ticket by navigating to our Developer Support Center.

First, I would make sure that when making these requests the user in question is under the same account as the JWT token. I don’t have the tools to confirm if this is the case just yet but if you create a ticket I can follow up with you there.

Thanks,
Max

Hello @MaxM

[Request #12529977]
(https://support.zoom.us/hc/en-us/requests/12529977)

I have posted a ticket.
Someone set it to solved right away without apparently solving anything, so i posted a follow-up as well.

I have posted a ticket as max above told me.
it looks like the tickets have been deleted already though.

could you let me know what i have to do next to get help?